summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-05 18:23:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-05 18:24:33 +0200
commit90fda681f8c087e7d238aeb8cacd078ff9d94b0e (patch)
treeae762b87414f252ed4a32d9c57d57b5930085906 /dev-python/xlrd
parentdev-python/cairocffi: Port to py39, remove docs (diff)
downloadgentoo-90fda681f8c087e7d238aeb8cacd078ff9d94b0e.tar.gz
gentoo-90fda681f8c087e7d238aeb8cacd078ff9d94b0e.tar.bz2
gentoo-90fda681f8c087e7d238aeb8cacd078ff9d94b0e.zip
dev-python/xlrd: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/xlrd-1.2.0.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-python/xlrd/xlrd-1.2.0.ebuild b/dev-python/xlrd/xlrd-1.2.0.ebuild
index b3782f1a8139..d2dac8fad320 100644
--- a/dev-python/xlrd/xlrd-1.2.0.ebuild
+++ b/dev-python/xlrd/xlrd-1.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,16 +14,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+distutils_enable_tests unittest
python_prepare_all() {
# Remove this if examples get reintroduced
sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
-}