summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 16:43:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 16:43:07 +0200
commit05e7862f53b40db436fd69cc56e24641a079dbf0 (patch)
treeb39410b6c40db88eb979796284318374a91c4ee2 /dev-python
parentdev-python/littleutils: PEP517, py3.12 (diff)
downloadgentoo-05e7862f53b40db436fd69cc56e24641a079dbf0.tar.gz
gentoo-05e7862f53b40db436fd69cc56e24641a079dbf0.tar.bz2
gentoo-05e7862f53b40db436fd69cc56e24641a079dbf0.zip
dev-python/minikanren: PEP517, py3.12
Closes: https://bugs.gentoo.org/909922 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/minikanren/Manifest1
-rw-r--r--dev-python/minikanren/minikanren-1.0.3-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/minikanren/Manifest b/dev-python/minikanren/Manifest
index 861d47436e4b..2fe9871c337e 100644
--- a/dev-python/minikanren/Manifest
+++ b/dev-python/minikanren/Manifest
@@ -1 +1,2 @@
+DIST kanren-1.0.3.gh.tar.gz 72998 BLAKE2B fcbc852d1dfeef4dbe0b4f2daa36fa87f8e6b597d6f8dc80d3197b8d151aa0ffa1234a2677b5c430e3431cf826ff44d1c8954f043d3a8976970f73d403ccb544 SHA512 913930d98c006e355f700087f00bb002e93a68c782b6a8cba003242747a8060789a113f380199124a1499beca8d8399df73db9a003a6719a90378db86b2fc166
DIST minikanren-1.0.3.gh.tar.gz 73008 BLAKE2B 6fdc605249ac06071a8b51e736d19f561288a293853e8b7ac8685f5b4da400aa8ae480b9a6e5eac3a5735ebe00567e52f24d4bf6afbffb7678e0d41553e1b12f SHA512 b65095b947d3b59496035f54a00fcddaa1888dec1cb8117086bbb16f5b4ed1bf59f2b79e3639f06a4347bd22b7fb4753734f5b8da149a3d470521f360fba5d2e
diff --git a/dev-python/minikanren/minikanren-1.0.3-r1.ebuild b/dev-python/minikanren/minikanren-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..8f8f6317b8a8
--- /dev/null
+++ b/dev-python/minikanren/minikanren-1.0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=kanren-${PV}
+DESCRIPTION="Relational programming in Python"
+HOMEPAGE="
+ https://pypi.org/project/miniKanren/
+ https://github.com/pythological/kanren/
+"
+SRC_URI="
+ https://github.com/pythological/kanren/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest