summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-16 17:00:42 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-16 17:00:42 +0200
commit09a9b86175307c3aa3054f4466c56eb0c0d765a2 (patch)
tree69a198d61e7a7e3de60327ff913a662ac361c57c /dev-python
parentdev-util/pmd: remove last-rited package (diff)
downloadgentoo-09a9b86175307c3aa3054f4466c56eb0c0d765a2.tar.gz
gentoo-09a9b86175307c3aa3054f4466c56eb0c0d765a2.tar.bz2
gentoo-09a9b86175307c3aa3054f4466c56eb0c0d765a2.zip
dev-python/pyGPG: Update live ebuild
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
index d1140338e37a..a5839bdc60dd 100644
--- a/dev-python/pyGPG/pyGPG-9999.ebuild
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -1,35 +1,33 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-EGIT_BRANCH="master"
+inherit distutils-r1
-inherit distutils-r1 python-r1 git-2
-
-EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
DESCRIPTION="A python interface wrapper for gnupg's gpg command"
HOMEPAGE="https://github.com/dol-sen/pyGPG"
-SRC_URI=""
LICENSE="BSD"
SLOT="0"
IUSE=""
-KEYWORDS=""
-
DEPEND=""
RDEPEND="${DEPEND}
app-crypt/gnupg
"
-python_install_all() {
- distutils-r1_python_install_all
-}
-
pkg_postinst() {
einfo
einfo "This is experimental software."