summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-18 06:10:27 +0000
committerSam James <sam@gentoo.org>2023-02-18 06:10:44 +0000
commit2ef51e78d89b3f25028e1b63693d28d1aebbd991 (patch)
treeba7bceba66d4dbf5f2f80a06b130b225bcc39e96 /dev-python
parentsys-kernel/rt-sources: add 5.15.94_p59, drop 5.15.93_p58 (diff)
downloadgentoo-2ef51e78d89b3f25028e1b63693d28d1aebbd991.tar.gz
gentoo-2ef51e78d89b3f25028e1b63693d28d1aebbd991.tar.bz2
gentoo-2ef51e78d89b3f25028e1b63693d28d1aebbd991.zip
dev-python/pyrqlite: enable py3.11, use PEP517
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild b/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..e267aec4f7bc
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="https://github.com/rqlite/pyrqlite"
+SRC_URI="https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/rqlite/pyrqlite/pull/42.patch -> ${P}-test_cPragmaTableInfo.patch"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( >=dev-db/rqlite-6.7.0 )"
+
+PATCHES=( "${DISTDIR}/${P}-test_cPragmaTableInfo.patch" )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
+ distutils-r1_src_prepare
+}