summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 13:19:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 13:32:06 +0200
commit4a8e5eb46c7282de94d1afdb80a93ea352744832 (patch)
treedac49df28665a1cc93d4e2aa1bd782efdfe2f068 /dev-python
parentdev-python/lmfit: Remove old (diff)
downloadgentoo-4a8e5eb46c7282de94d1afdb80a93ea352744832.tar.gz
gentoo-4a8e5eb46c7282de94d1afdb80a93ea352744832.tar.bz2
gentoo-4a8e5eb46c7282de94d1afdb80a93ea352744832.zip
dev-python/loguru: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/loguru/Manifest2
-rw-r--r--dev-python/loguru/files/0.6.0-py311-fix.patch68
-rw-r--r--dev-python/loguru/files/0.6.0-typos.patch45
-rw-r--r--dev-python/loguru/loguru-0.6.0-r1.ebuild41
4 files changed, 0 insertions, 156 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
index 45dda10e1dec..63c4e36dc3ec 100644
--- a/dev-python/loguru/Manifest
+++ b/dev-python/loguru/Manifest
@@ -1,3 +1 @@
-DIST loguru-0.6.0-py311-repr-tests.patch 4251 BLAKE2B 21891ede1845387f915d3889dfb077af78e88909ce7efe25cd194516dab465738d3c398195552e8a8a54913804df1bc74bf95c4e12494b8e7f628894d0c12177 SHA512 e1da062ba49e53ecfedc044d59f969797bd1dec99c64e42d5420af6cba80db95d242ed7d155b180e84dacba4bd56298fd5a4cae784ef4eec1709905da1a1c93f
-DIST loguru-0.6.0.gh.tar.gz 417660 BLAKE2B a7b7d95ffcf652769503db3423768ff85a4fa4898f0e2b155d96ce0c42fa7f24255f9dc49ba62e8a4f19bb3b7cc8b374580fe0965c9683b14d9bcea9866e71a5 SHA512 6ca7087cde3b4ce11255e31af988e5e118a7ebfbb338b97ebd6e7e4af716f0301c0180a59b18c879fd799c25802b428411b868290b7593212f06d70bcbd6a9ca
DIST loguru-0.7.0.gh.tar.gz 430544 BLAKE2B 13ee91da7c7bc0b29297cb70235c26e0517939c332dde342c14cb937112d5a0b9c467ec273f2034875a52902ffc05dd780fd349498d8a0b65efd6ecf6a947056 SHA512 02d2a0c7c54a5083a444a23222854ee4587da3f7a490ec193d0bae2f3c464c0a86102417f5886205e73c0a149694b931f39f3c5a1ade605cf2b2799395a478a0
diff --git a/dev-python/loguru/files/0.6.0-py311-fix.patch b/dev-python/loguru/files/0.6.0-py311-fix.patch
deleted file mode 100644
index a7d29b911fac..000000000000
--- a/dev-python/loguru/files/0.6.0-py311-fix.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Fix failing tests on Python 3.11 (#654)
-
-Issue: https://github.com/Delgan/loguru/issues/654
-Commit: https://github.com/Delgan/loguru/commit/5b77724ca75aa8f4b1c8866e0b786c3cbe30ca99
-
-diff --git a/tests/test_filesink_rotation.py b/tests/test_filesink_rotation.py
-index bdf75a3..fb80b69 100644
---- a/tests/test_filesink_rotation.py
-+++ b/tests/test_filesink_rotation.py
-@@ -49,8 +49,8 @@ def monkeypatch_filesystem(monkeypatch):
- return self._timestamp
- return getattr(self._wrapped, name)
-
-- def patched_stat(filepath):
-- stat = __stat__(filepath)
-+ def patched_stat(filepath, *args, **kwargs):
-+ stat = __stat__(filepath, *args, **kwargs)
- wrapped = StatWrapper(stat, filesystem.get(os.path.abspath(filepath)))
- return wrapped
-
-diff --git a/tests/test_interception.py b/tests/test_interception.py
-index a05802a..2f570b9 100644
---- a/tests/test_interception.py
-+++ b/tests/test_interception.py
-@@ -1,4 +1,5 @@
- import logging
-+import sys
-
- from loguru import logger
-
-@@ -7,15 +8,15 @@ from .conftest import make_logging_logger
-
- class InterceptHandler(logging.Handler):
- def emit(self, record):
-- # Get corresponding Loguru level if it exists
-+ # Get corresponding Loguru level if it exists.
- try:
- level = logger.level(record.levelname).name
- except ValueError:
- level = record.levelno
-
-- # Find caller from where originated the logged message
-- frame, depth = logging.currentframe(), 2
-- while frame.f_code.co_filename == logging.__file__:
-+ # Find caller from where originated the logged message.
-+ frame, depth = sys._getframe(6), 6
-+ while frame and frame.f_code.co_filename == logging.__file__:
- frame = frame.f_back
- depth += 1
-
-@@ -30,7 +31,7 @@ def test_formatting(writer):
-
- expected = (
- "tests.test_interception - test_interception.py - test_formatting - DEBUG - "
-- "10 - 38 - test_interception - This is the message\n"
-+ "10 - 39 - test_interception - This is the message\n"
- )
-
- with make_logging_logger("tests", InterceptHandler()) as logging_logger:
-@@ -157,4 +158,4 @@ def test_using_logging_function(writer):
- logging.warning("ABC")
-
- result = writer.read()
-- assert result == "test_using_logging_function 157 test_interception test_interception.py ABC\n"
-+ assert result == "test_using_logging_function 158 test_interception test_interception.py ABC\n"
---
-2.39.2
-
diff --git a/dev-python/loguru/files/0.6.0-typos.patch b/dev-python/loguru/files/0.6.0-typos.patch
deleted file mode 100644
index ed9fecc91bfd..000000000000
--- a/dev-python/loguru/files/0.6.0-typos.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 8b820c7a138f0b320311c85e8ea6e1c017576000 Mon Sep 17 00:00:00 2001
-From: Delgan <4193924+Delgan@users.noreply.github.com>
-Date: Sat, 29 Jan 2022 14:50:59 +0100
-Subject: [PATCH 1/2] Fix small typo in CHANGELOG.md
-
----
- CHANGELOG.rst | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CHANGELOG.rst b/CHANGELOG.rst
-index 4c57fad..1d08f9d 100644
---- a/CHANGELOG.rst
-+++ b/CHANGELOG.rst
-@@ -184,7 +184,7 @@ Initial release.
-
-
- .. _Unreleased: https://github.com/delgan/loguru/compare/0.6.0...master
--.. -0.6.0: https://github.com/delgan/loguru/releases/tag/0.6.0
-+.. _0.6.0: https://github.com/delgan/loguru/releases/tag/0.6.0
- .. _0.5.3: https://github.com/delgan/loguru/releases/tag/0.5.3
- .. _0.5.2: https://github.com/delgan/loguru/releases/tag/0.5.2
- .. _0.5.1: https://github.com/delgan/loguru/releases/tag/0.5.1
-
-From ee1ce85a047fc396276e10ae92b72610cbafd57b Mon Sep 17 00:00:00 2001
-From: Delgan <4193924+Delgan@users.noreply.github.com>
-Date: Sun, 30 Jan 2022 20:28:37 +0100
-Subject: [PATCH 2/2] Fix another small typo in CHANGELOG.rst
-
----
- CHANGELOG.rst | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CHANGELOG.rst b/CHANGELOG.rst
-index 1d08f9d..6e1c182 100644
---- a/CHANGELOG.rst
-+++ b/CHANGELOG.rst
-@@ -1,7 +1,7 @@
- `0.6.0`_ (2022-01-29)
- =====================
-
--- Remove internal use of ``pickle.loads()`` considered as a security vulnerability referenced as `CVE-2022-0329 https://nvd.nist.gov/vuln/detail/CVE-2022-0329`_ (`#563 <https://github.com/Delgan/loguru/issues/563>`_).
-+- Remove internal use of ``pickle.loads()`` considered as a security vulnerability referenced as `CVE-2022-0329 <https://nvd.nist.gov/vuln/detail/CVE-2022-0329>`_ (`#563 <https://github.com/Delgan/loguru/issues/563>`_).
- - Modify coroutine sink to make it discard log messages when ``loop=None`` and no event loop is running (due to internally using ``asyncio.get_running_loop()`` in place of ``asyncio.get_event_loop()``).
- - Remove the possibility to add a coroutine sink with ``enqueue=True`` if ``loop=None`` and no event loop is running.
- - Change default encoding of file sink to be ``utf8`` instead of ``locale.getpreferredencoding()`` (`#339 <https://github.com/Delgan/loguru/issues/339>`_).
diff --git a/dev-python/loguru/loguru-0.6.0-r1.ebuild b/dev-python/loguru/loguru-0.6.0-r1.ebuild
deleted file mode 100644
index d4b4aeee1ce2..000000000000
--- a/dev-python/loguru/loguru-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python logging made (stupidly) simple"
-HOMEPAGE="
- https://github.com/Delgan/loguru/
- https://pypi.org/project/loguru/
-"
-SRC_URI="
- https://github.com/Delgan/loguru/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://github.com/Delgan/loguru/commit/4fe21f66991abeb1905e24c3bc3c634543d959a2.patch
- -> ${P}-py311-repr-tests.patch
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-BDEPEND="
- test? (
- >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PV}-typos.patch"
- "${FILESDIR}/${PV}-py311-fix.patch"
- "${DISTDIR}/${P}-py311-repr-tests.patch"
-)
-
-# filesystem buffering tests may fail
-# on tmpfs with 64k PAGESZ, but pass fine on ext4
-distutils_enable_tests pytest