summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 19:59:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 20:09:17 +0200
commit507004581217d1c31d9c400849157fac9530ef7a (patch)
tree4d3983c739f9918da7ff46f22d08d24b74fd6dcf /dev-python
parentapp-admin/opentofu: add 1.7.2 (diff)
downloadgentoo-507004581217d1c31d9c400849157fac9530ef7a.tar.gz
gentoo-507004581217d1c31d9c400849157fac9530ef7a.tar.bz2
gentoo-507004581217d1c31d9c400849157fac9530ef7a.zip
dev-python/mkdocs-gen-files: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild b/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild
index c3da12db2be8..f5924f0e0336 100644
--- a/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild
+++ b/dev-python/mkdocs-gen-files/mkdocs-gen-files-0.5.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -18,7 +18,13 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv"
-RDEPEND=">=dev-python/mkdocs-1.0.3[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/pytest-golden[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/mkdocs-1.0.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-golden[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest