summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-02 04:24:17 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-02 04:24:17 +0200
commit532933825d98ff36a0e839903b87afb7fca2cb60 (patch)
tree4b4460eba9214db61ceefe7f3ddba4092aa8da5a /dev-python
parentdev-ruby/power_assert: actually EAPI 8 (diff)
downloadgentoo-532933825d98ff36a0e839903b87afb7fca2cb60.tar.gz
gentoo-532933825d98ff36a0e839903b87afb7fca2cb60.tar.bz2
gentoo-532933825d98ff36a0e839903b87afb7fca2cb60.zip
dev-python/confuse: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/confuse/Manifest1
-rw-r--r--dev-python/confuse/confuse-2.0.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/confuse/Manifest b/dev-python/confuse/Manifest
index d697b03cbb94..9cc8b0b4d140 100644
--- a/dev-python/confuse/Manifest
+++ b/dev-python/confuse/Manifest
@@ -1 +1,2 @@
DIST confuse-2.0.0.gh.tar.gz 48269 BLAKE2B 58b96ab65da7b48236b798ad5546a72f0f74934c42525b26b44c0aad08ba4de385dbc2dd6915a4b570b1c4e59003e23119f0da80cf84b1bbc88abb9f72d4d8b1 SHA512 53732ef24903bc464f4cda0c9a2728814ff286c2e2a2150b4703b61f925d5bf77d75b98469a4fb92267caeec736e51d33285264f3fd8daa4adaaf23fa9511733
+DIST confuse-2.0.1.tar.gz 50872 BLAKE2B fc28d6109abec7a233ade85de35ba10264261eb37367fbfa7b6719399cedffc87da3c0bb563b8d9524551cf11ff679896e0a8cc123e08f5291c40d04ffcfe314 SHA512 fe9e17d3b321079290fa2c7db64cd5664db11f1277fe608cf5a1419254b83eee9bc169e34631a429ab1bf47779ea709156b8310a97e65fae32a20802b379fa76
diff --git a/dev-python/confuse/confuse-2.0.1.ebuild b/dev-python/confuse/confuse-2.0.1.ebuild
new file mode 100644
index 000000000000..f19d138dcfe9
--- /dev/null
+++ b/dev-python/confuse/confuse-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="
+ https://github.com/beetbox/confuse/
+ https://pypi.org/project/confuse/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx-rtd-theme'