summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 07:13:21 +0100
committerSam James <sam@gentoo.org>2022-06-01 07:31:47 +0100
commit6652946eb6859d42afece08dc16c1f94317be9d6 (patch)
tree4bbf566c928d808126a1636e0bc8405a9a1c69a0 /dev-python
parentdev-python/ruamel-yaml: enable py3.11 (diff)
downloadgentoo-6652946eb6859d42afece08dc16c1f94317be9d6.tar.gz
gentoo-6652946eb6859d42afece08dc16c1f94317be9d6.tar.bz2
gentoo-6652946eb6859d42afece08dc16c1f94317be9d6.zip
dev-python/krb5: recythonise for Python 3.11 support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/krb5/krb5-0.3.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/krb5/krb5-0.3.0-r1.ebuild b/dev-python/krb5/krb5-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..235f1e541e46
--- /dev/null
+++ b/dev-python/krb5/krb5-0.3.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Kerberos API bindings for Python"
+HOMEPAGE="https://pypi.org/project/krb5/ https://github.com/jborean93/pykrb5"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ virtual/krb5
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/k5test[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # Needed for Python 3.11, can drop in next release (after 0.3.0)
+ cd src/krb5 || die
+ rm _*.c || die
+ cythonize -f -3 *.pyx || die
+}