summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-14 05:34:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-14 05:59:23 +0200
commit7439b88c204b1c5ddac97d06b6e906e3c0ab81c6 (patch)
tree0d76c30d5c12a34815f10a5cc1b2a1285f5ccde0 /dev-python
parentdev-python/pyfakefs: Bump to 5.2.2 (diff)
downloadgentoo-7439b88c204b1c5ddac97d06b6e906e3c0ab81c6.tar.gz
gentoo-7439b88c204b1c5ddac97d06b6e906e3c0ab81c6.tar.bz2
gentoo-7439b88c204b1c5ddac97d06b6e906e3c0ab81c6.zip
dev-python/ansible-compat: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-3.0.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 3824431f256e..ce53b5dfa8f1 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
DIST ansible-compat-3.0.1.tar.gz 62676 BLAKE2B a1d08311e1b61d8387ef82db65581df4ab7cb4a2520bff9173845fa5b9fe18d173afd4306874967fb40c007546f36d78349a503bd09ae14257a38a59e1cbb22f SHA512 27183b09f957a79254b5dfa237c2ef789dac95e86f421277878a57487a16684de862f03f6ecee6c57ab5a5dfa8c7ee2802d5e63e74ca0aebc61efa46574f0a61
+DIST ansible-compat-3.0.2.tar.gz 63328 BLAKE2B d09ae255e08531b26f8cac7082a3ad0cc24f3772b7769b75d644a846dcc1ec0ff65fe1a7e351eeecadd70caae5ef5b5146396df5ec586e10296e116310333e6b SHA512 79f20a25b25104f4f90a4d52317bd01ceb07c00c69dc2e61b74b4c7448805bd966d001893ccf7530bec819ae9ead2515ae70219a887fda733344245cc025dfeb
diff --git a/dev-python/ansible-compat/ansible-compat-3.0.2.ebuild b/dev-python/ansible-compat/ansible-compat-3.0.2.ebuild
new file mode 100644
index 000000000000..bbea175e5664
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-3.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_tests pytest