summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 13:21:10 +0100
committerSam James <sam@gentoo.org>2021-04-18 07:01:25 +0100
commit794adf45ecc6156c314e1436843ede4f0237eb76 (patch)
tree826d314e0b01ccd6b5b16c4cf387219974e1ba74 /dev-python
parentdev-python/cheetah-docs: eutils-- (diff)
downloadgentoo-794adf45ecc6156c314e1436843ede4f0237eb76.tar.gz
gentoo-794adf45ecc6156c314e1436843ede4f0237eb76.tar.bz2
gentoo-794adf45ecc6156c314e1436843ede4f0237eb76.zip
dev-python/simplegeneric: use BDEPEND for app-arch/unzip
Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
index 4a3ada9a491b..8ab32da7b1eb 100644
--- a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
+++ b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
@@ -13,10 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py