summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-06-19 21:24:52 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-19 21:24:52 -0400
commit82b53492a843395480fa31cd0b098a532a3eef40 (patch)
treeeb7bbbfc2f3aea07e9fea01d30e70b081c54a104 /dev-python
parentapp-emulation/skopeo: drop vulnerable (diff)
downloadgentoo-82b53492a843395480fa31cd0b098a532a3eef40.tar.gz
gentoo-82b53492a843395480fa31cd0b098a532a3eef40.tar.bz2
gentoo-82b53492a843395480fa31cd0b098a532a3eef40.zip
dev-python/reportlab: drop vulnerable
Bug: https://bugs.gentoo.org/710738 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.5.13-r1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 8e8f474e6162..200e6e1d0aa9 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,3 +1,2 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
-DIST reportlab-3.5.13.tar.gz 2842790 BLAKE2B 1457b5eb18d2f294decd7bbee202f42900a443eb7a31c2af56cc2180154e1bb48c4044c499b14489c23210e78c9bafb3fbbcd0c5a28f1d2e25f57d91dcb48526 SHA512 50afcdb5e844cc7ec5c1cf72ca28556e98ad721dce5b20cfb32fa720d56b221b9bd2662a88ea5647b11306d80e653334635b54165daa02d3062cf9d051bbd24b
DIST reportlab-3.5.42.tar.gz 2883081 BLAKE2B 22f4e7ebc233895a036eeb94c5beb9206be561a8a44895b36291a4f840603a2fec90107ac60e749f99be629202801c63ff67d5034d19b42383f2df12d457104d SHA512 f52717867190bf7812fd566d9ec3044198db809cdd0f53cc9dbfa92503a202540db659369e20bba3de07cd28eb10515d03b85700ac138c9394dc9eed1f08b8f8
diff --git a/dev-python/reportlab/reportlab-3.5.13-r1.ebuild b/dev-python/reportlab/reportlab-3.5.13-r1.ebuild
deleted file mode 100644
index 23688607e2a9..000000000000
--- a/dev-python/reportlab/reportlab-3.5.13-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} ) # Tests crash with pypy
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Tools for generating printable PDF documents from any data source"
-HOMEPAGE="http://www.reportlab.com/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
- http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
- media-libs/libart_lgpl
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.5.13-disable-network-tests.patch"
- "${FILESDIR}/${PN}-3.5.13-pillow-VERSION.patch"
-)
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${P}/src/reportlab/fonts || die
- unpack pfbfer-20070710.zip
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd tests > /dev/null || die
- "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- if use examples ; then
- docinto examples
- dosod -r demos/. tools/pythonpoint/demos
- fi
-
- distutils-r1_python_install_all
-}