summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-10-15 21:50:43 -0400
committerMike Gilbert <floppym@gentoo.org>2015-10-15 21:50:43 -0400
commit86e5533e18663f26a8f9af19b42169c818fc0c63 (patch)
treead36c1b45b92054d4db801eb1ad86ce03ee17d7c /dev-python
parentx11-misc/fireflies: 2.08 (diff)
downloadgentoo-86e5533e18663f26a8f9af19b42169c818fc0c63.tar.gz
gentoo-86e5533e18663f26a8f9af19b42169c818fc0c63.tar.bz2
gentoo-86e5533e18663f26a8f9af19b42169c818fc0c63.zip
dev-python/lockfile: Remove upper-bound on dev-python/pbr
Package-Manager: portage-2.2.23_p4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/lockfile/lockfile-0.11.0-r1.ebuild (renamed from dev-python/lockfile/lockfile-0.11.0.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/lockfile/lockfile-0.11.0.ebuild b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
index 97ebd77cde52..1979687a3a4e 100644
--- a/dev-python/lockfile/lockfile-0.11.0.ebuild
+++ b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
@@ -19,13 +19,17 @@ IUSE="doc test"
DEPEND="
>dev-python/pbr-0.7[${PYTHON_USEDEP}]
- <dev-python/pbr-1[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=""
DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
+python_prepare_all() {
+ rm requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
if use doc; then
einfo "Generation of documentation"