summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-05-07 11:11:08 -0700
committerMichał Górny <mgorny@gentoo.org>2017-05-09 19:18:34 +0200
commit9448ce017d968c8ced8e8026040e09d0d5e4a5c5 (patch)
treeb9f9c8beabea6ca46e533895957bf86567190623 /dev-python
parentdev-libs/protobuf: version bump to 3.3.0 (diff)
downloadgentoo-9448ce017d968c8ced8e8026040e09d0d5e4a5c5.tar.gz
gentoo-9448ce017d968c8ced8e8026040e09d0d5e4a5c5.tar.bz2
gentoo-9448ce017d968c8ced8e8026040e09d0d5e4a5c5.zip
dev-python/protobuf-python: version bump to 3.3.0
Change license from Apache-2.0 to BSD Fix python3 incompatibility in patch Bug: https://bugs.gentoo.org/460608
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/protobuf-python/Manifest1
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch4
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.1.0.ebuild2
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.3.0.ebuild39
4 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index 87f950260d61..eefcfffce43e 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1 +1,2 @@
DIST protobuf-3.1.0.tar.gz 4051503 SHA256 0a0ae63cbffc274efb573bdde9a253e3f32e458c41261df51c5dbc5ad541e8f7 SHA512 8d3289a16944c255bd1cceab696e515e52467f2bfe1cc10f6b32fabdf082d5acdc248ec9cadc572223a24d04d431f75921076153109cea2f90ee533f502ab47a WHIRLPOOL b8a0bee9ff549c8da45c2b56b12aafbed5807959cdb11b3888a0f30fd0d6df83a72f3c6ef9e266522754b8901792f65235a6e81a8b0f74cee15d59ecbe6dee68
+DIST protobuf-3.3.0.tar.gz 4336596 SHA256 94c414775f275d876e5e0e4a276527d155ab2d0da45eed6b7734301c330be36e SHA512 0734a55ae92f0539dfb507e174539d290fd8e93633c1edd8810e0d51c37e67254337b75fc5ba9450316f6416e1f8f8cfb59415864657b55f2a1696fbcdfe7636 WHIRLPOOL 4c18120ad784234ebb5308c0f3a2f3814d77f2fc906407f48285f3ba8f84af8e15defa4e7edf2d2e77cf22316df338b3f5bc0c6ca11c7a4fb951105c3aa7d7d4
diff --git a/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
index cb4a5f6cf7eb..c0b7aadcd6f5 100644
--- a/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
+++ b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
@@ -9,8 +9,8 @@ diff -Naur python/setup.py python/setup.py
+ libD = []
+ try:
+ subprocess.check_call(['pkg-config', '--exists', 'protobuf'])
-+ inclD += subprocess.check_output(['pkg-config','--variable=includedir','protobuf']).split()
-+ libD = subprocess.check_output(['pkg-config','--variable=libdir','protobuf']).split()
++ inclD += subprocess.check_output(['pkg-config','--variable=includedir','protobuf']).decode().split()
++ libD = subprocess.check_output(['pkg-config','--variable=libdir','protobuf']).decode().split()
+ except OSError as osex:
+ if osex.errno == errno.ENOENT:
+ info('pkg-config not found')
diff --git a/dev-python/protobuf-python/protobuf-python-3.1.0.ebuild b/dev-python/protobuf-python/protobuf-python-3.1.0.ebuild
index eccc393b3865..4a087b35a576 100644
--- a/dev-python/protobuf-python/protobuf-python-3.1.0.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-3.1.0.ebuild
@@ -14,7 +14,7 @@ DESCRIPTION="Google's Protocol Buffers - official Python bindings"
HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
SRC_URI="https://github.com/google/protobuf/archive/v${MY_PV}.tar.gz -> protobuf-${PV}.tar.gz"
-LICENSE="Apache-2.0"
+LICENSE="BSD"
SLOT="0/11"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE=""
diff --git a/dev-python/protobuf-python/protobuf-python-3.3.0.ebuild b/dev-python/protobuf-python/protobuf-python-3.3.0.ebuild
new file mode 100644
index 000000000000..c3076f1f5b6d
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# pypy fails tests; pypy3 fails even running tests
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/-beta-}
+MY_PV=${MY_PV/_p/.}
+
+DESCRIPTION="Google's Protocol Buffers - official Python bindings"
+HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
+SRC_URI="https://github.com/google/protobuf/archive/v${MY_PV}.tar.gz -> protobuf-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/13"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+# Protobuf is only a build-time dep, but depends on the exact same version
+# (excluding revision), since we are using the same tarball.
+# In case of using the (linked) cpp implementation we should be fine with the same subslot.
+RDEPEND="${PYTHON_DEPS}
+ !<dev-libs/protobuf-3[python(-)]
+ ~dev-libs/protobuf-${PV}"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-3.0.0_beta3-link-against-installed-lib.patch" )
+
+S="${WORKDIR}/protobuf-${MY_PV}/python"
+
+python_test() {
+ esetup.py test
+}