summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-03 21:07:23 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-03 21:27:27 +0200
commita00fdb44134cc0f5c1156a16e146813ae576471e (patch)
treeb24a6a3926acf967c078a65ab85a2d0920dedd40 /dev-python
parentapp-editors/vim: stable 8.2.3428-r1 for hppa, bug #816894 (diff)
downloadgentoo-a00fdb44134cc0f5c1156a16e146813ae576471e.tar.gz
gentoo-a00fdb44134cc0f5c1156a16e146813ae576471e.tar.bz2
gentoo-a00fdb44134cc0f5c1156a16e146813ae576471e.zip
dev-python/pyFFTW: enable tests
Closes: https://bugs.gentoo.org/798201 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyFFTW/pyFFTW-0.12.0-r1.ebuild31
1 files changed, 22 insertions, 9 deletions
diff --git a/dev-python/pyFFTW/pyFFTW-0.12.0-r1.ebuild b/dev-python/pyFFTW/pyFFTW-0.12.0-r1.ebuild
index 80870ef7a971..8ec87a34fe67 100644
--- a/dev-python/pyFFTW/pyFFTW-0.12.0-r1.ebuild
+++ b/dev-python/pyFFTW/pyFFTW-0.12.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="A pythonic python wrapper around FFTW"
@@ -11,7 +11,7 @@ HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
LICENSE="BSD"
SLOT="0"
-if [ "${PV}" = "9999" ]; then
+if [[ "${PV}" = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
else
@@ -19,11 +19,24 @@ else
SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
-IUSE=""
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3:3.0=[threads]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
-DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/fftw-3.3:3.0=[threads]"
-RDEPEND="${PYTHON_DEPS}
- ${DEPEND}"
-BDEPEND="${PYTHON_DEPS}
- dev-python/cython[${PYTHON_USEDEP}]"
+distutils_enable_tests unittest
+
+python_test() {
+ cp -r -l -n test/ "${BUILD_DIR}/lib" || die
+ cd "${BUILD_DIR}/lib" || die
+ eunittest
+ rm -r test/ || die
+}