summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-25 16:08:53 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-25 16:09:55 -0800
commitc38d7e49cb5e3917f6cc50b63f294c333e96893f (patch)
treeec8277f781cb1c3bcc0548d99a16302b8535ebab /dev-python
parentapp-emulation/wine-vanilla: Bump stable (diff)
downloadgentoo-c38d7e49cb5e3917f6cc50b63f294c333e96893f.tar.gz
gentoo-c38d7e49cb5e3917f6cc50b63f294c333e96893f.tar.bz2
gentoo-c38d7e49cb5e3917f6cc50b63f294c333e96893f.zip
dev-python/python-dateutil-2.8.1: Fix setuptools_scm removal
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.8.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/python-dateutil/python-dateutil-2.8.1.ebuild b/dev-python/python-dateutil/python-dateutil-2.8.1.ebuild
index f2c9ffa8ab98..f7e2ed073d29 100644
--- a/dev-python/python-dateutil/python-dateutil-2.8.1.ebuild
+++ b/dev-python/python-dateutil/python-dateutil-2.8.1.ebuild
@@ -43,7 +43,9 @@ distutils_enable_tests pytest
python_prepare_all() {
# avoid a setuptools_scm dependency
- sed -i "s:use_scm_version=True:version='${PV}':" setup.py || die
+ sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+ sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
+ setup.cfg || die
# don't install zoneinfo tarball
sed -i '/package_data=/d' setup.py || die