summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-22 16:19:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-22 16:19:33 +0200
commitc4790a8c2381ee3fb54925e7fa1122417d993141 (patch)
tree2449d8a4417d6dc8039ecc9fb2cc56ea4a9a0dd7 /dev-python
parentdev-lang/php: fix the 8.1.x build with gcc-14, icu-74, and USE=intl (diff)
downloadgentoo-c4790a8c2381ee3fb54925e7fa1122417d993141.tar.gz
gentoo-c4790a8c2381ee3fb54925e7fa1122417d993141.tar.bz2
gentoo-c4790a8c2381ee3fb54925e7fa1122417d993141.zip
dev-python/pytest-httpx: Bump to 0.31.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.31.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 0444f922d6f1..a33e877a4ed1 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,2 +1,3 @@
DIST pytest-httpx-0.30.0.tar.gz 36959 BLAKE2B b56f0e51558ffa6eb0c0af61aa3633a8e358f8c78916d101f1de853f683136a68e195bf0af099bbc6766198b4136a560ffd2676d9a49f0b350882896a61d935a SHA512 6aadb544bda5003156bf9c0fa309a166636dc87aea033d9a48ee10e1e8b77e6cb52350930e97cab89cff7c10111d5e26d1d74cd33f0a6c54e34c3fb7ef72ea05
DIST pytest_httpx-0.31.0.tar.gz 38352 BLAKE2B 0e9ad5507ad4fe209dcf6a0b0077b0a16eb534fd3c6abe0f2e89f8b1bdc4761274e200ed8497da6df89778cccbea4af6ed06ca5fa61ba4cdd9b1164d540a09be SHA512 4c2fa27b0a6f4677dd237bd10661e668c1cb587ffa8196c715a4a66d85c47007813687b27afc217a6e20deb2b5ab013fa4b43bfe41590b6b17fdd85370aee34a
+DIST pytest_httpx-0.31.1.tar.gz 38816 BLAKE2B 4e5fde73f0cf47a425b9ee666a13cbb01b2ef43b0c4c9c389e700000c5f3cb74b0e210da0de891b10c2e6aa51da018047ae9d61ceddac2f2be46295982e96fd7 SHA512 bd8a90bc3989a948a8420cd57a14cee7933b1207430286d8814c28c3f65238d6ea0abb43e9ed60fad06b40855d90438c62c57ba91c24590bcccd1698e0df1edf
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.31.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.31.1.ebuild
new file mode 100644
index 000000000000..eab60d4c7025
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.31.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ =dev-python/pytest-8*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest