summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 17:27:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 17:29:30 +0200
commitde4236df54e0dd614a526b4408819ef9e73e8388 (patch)
tree2bded64c29c1f4b260d20212cf950b4204683f09 /dev-python
parentdev-python/cachelib: Enable py3.11 (diff)
downloadgentoo-de4236df54e0dd614a526b4408819ef9e73e8388.tar.gz
gentoo-de4236df54e0dd614a526b4408819ef9e73e8388.tar.bz2
gentoo-de4236df54e0dd614a526b4408819ef9e73e8388.zip
dev-python/kombu: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/kombu/Manifest1
-rw-r--r--dev-python/kombu/kombu-5.3.0_beta2.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index 7f6c66b735ee..bde667a3263d 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,2 +1 @@
-DIST kombu-5.3.0b2.tar.gz 434341 BLAKE2B 6d5188f7682ccf2daa6ca4ed0fec7988cd4781954be0fdc847c18e47d5c425a657c3df0f5bda7999c764de293626e119a4645e92ff7bf23328f4fcb9d6f4cd4a SHA512 3000577cc3b2acfb378396640245f2bdf4c9e5e1d45252a27e4e168e22ff4070f480ad1fd70059b24cd710c452924bff1716f69bedcf020446f428f0967de832
DIST kombu-5.3.0b3.tar.gz 436058 BLAKE2B d8470eea43a1d5f862d93e3b3608a3240b25cad6ccb342318a7bebda17e6ce818dce2889cb7af22fd77d2f6e69d1fdfa6926c77ba715c76dd40e973f3d9920dc SHA512 c330e1dd334810ed5fdeea234c49606aa8e43f84006703ff26d900f40ec7ce4920418bef3fd43abc8c792fb750499031191394475c45bfac50f7d29a6e30f5f8
diff --git a/dev-python/kombu/kombu-5.3.0_beta2.ebuild b/dev-python/kombu/kombu-5.3.0_beta2.ebuild
deleted file mode 100644
index b44966b72721..000000000000
--- a/dev-python/kombu/kombu-5.3.0_beta2.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="AMQP Messaging Framework for Python"
-HOMEPAGE="
- https://github.com/celery/kombu/
- https://pypi.org/project/kombu/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/py-amqp-5.1.1[${PYTHON_USEDEP}]
- <dev-python/py-amqp-6.0.0[${PYTHON_USEDEP}]
- dev-python/vine[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- app-arch/brotli[python,${PYTHON_USEDEP}]
- >=dev-python/boto3-1.22.2[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- >=dev-python/pymongo-4.1.1[${PYTHON_USEDEP}]
- dev-python/Pyro4[${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[${PYTHON_USEDEP}]
- dev-python/zstandard[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/redis-4.2.2[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_celery
-
-EPYTEST_IGNORE=(
- # Unpackaged azure-servicebus
- t/unit/transport/test_azureservicebus.py
- # Unpackaged librabbitmq
- t/unit/transport/test_librabbitmq.py
- # Unpackaged python-consul
- t/unit/transport/test_consul.py
- # AttributeError: test_Etcd instance has no attribute 'patch'
- t/unit/transport/test_etcd.py
-)
-
-python_test() {
- local EPYTEST_DESELECT
-
- # AttributeError: 'str' object has no attribute 'load'
- [[ ${EPYTHON} == python3.10 ]] && \
- EPYTEST_DESELECT+=( t/unit/utils/test_compat.py::test_entrypoints )
-
- epytest
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Amazon SQS backend" "dev-python/boto3 dev-python/pycurl"
- optfeature "Etcd backend" dev-python/python-etcd
- optfeature "MongoDB backend" dev-python/pymongo
- optfeature "Pyro 4 backend" dev-python/Pyro4
- optfeature "Redis backend" dev-python/redis
- optfeature "sqlalchemy backend" dev-python/sqlalchemy
- optfeature "yaml backend" dev-python/pyyaml
- optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
- optfeature "brotli compression" "app-arch/brotli[python]"
- optfeature "zstd compression" dev-python/zstandard
-}