summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-05 08:52:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-05 09:30:55 +0300
commite906b11c1810d679aad5759e0d21ef45f7467408 (patch)
tree553784c087bdabc88d8f0b1ccd94e9fcf5052919 /dev-python
parentsys-libs/llvm-libunwind: update HOMEPAGE (diff)
downloadgentoo-e906b11c1810d679aad5759e0d21ef45f7467408.tar.gz
gentoo-e906b11c1810d679aad5759e0d21ef45f7467408.tar.bz2
gentoo-e906b11c1810d679aad5759e0d21ef45f7467408.zip
dev-python/botocore: add 1.27.46
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.46.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d3b06f72603d..fe502b8c65ed 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.27.42.gh.tar.gz 9493679 BLAKE2B 324c574bfa30b26428010750d1488a81
DIST botocore-1.27.43.gh.tar.gz 9495496 BLAKE2B b445d81c9d56b4440e689559da576b82dc36c0c6cc8009ab97df16e5b012078b66367f4ce2140296b193d6fe729ddfeeae6fb3d561aab9a5018b18b1e62430c4 SHA512 f9314ed1dbca83c33f81f6454ada6566a401a9ce60dd77fbe491e0b8a5feab91161c953cbd6092c086fd9bbd4b2c8c6a0c9711941e1c8e96436d9062523ff656
DIST botocore-1.27.44.gh.tar.gz 9498149 BLAKE2B 233abf5899b1855bda0128ddc1cfed8def2ad76253e972d25ca36459fea14a87f3f99aa2c586bac798bbf7dea1b02693f7f361383c80b7c8b2e7c22f2cd92279 SHA512 b34d4fb5eff7de44f2c842e9ebc31119780f731362279b0a1384d608810dd677a90e9c4735cd709303e1190125b530ba721617ecd39aa17de5c3b5b82b97dc93
DIST botocore-1.27.45.gh.tar.gz 9501193 BLAKE2B 83bdab59babdaec8665be39089a6be298156065eec6058e89e405dfed5cc0caa0156404efaa9ac991cc6e2dbed0a93901232f1c3a174ba8012f07d54e68fab7f SHA512 7a334c124ee77f26d249d4bb95caf29397472534c682967d3c64db07f6872a986555ad7ccaed5ac49eb2b2ddf9179156e488f9743bc50cdb57daf5a80373d0c9
+DIST botocore-1.27.46.gh.tar.gz 9502831 BLAKE2B 75b4ada461e43573c202efdf12201dad8af017ec85c82d0e7cf9ba1823dfd988d4432daef13891a9b8063003a37432a041847cedf46d4665305f486f498edd8c SHA512 1b7719f2216ea170b8739811da2e11acf033919d826c138aa069b19250036b1b2f2cf276d71e464afc6fff63ed99333e6cc321e84139b55e02dea365aa71adc3
diff --git a/dev-python/botocore/botocore-1.27.46.ebuild b/dev-python/botocore/botocore-1.27.46.ebuild
new file mode 100644
index 000000000000..6558cbe56a50
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.46.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}