summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-23 05:32:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-23 05:48:31 +0200
commitf3877091a0bfc53ba1cb3d0a11faabc777a529c5 (patch)
treef8fff4e87e1b632b97f6614acde28a1cc9231ce2 /dev-python
parentdev-python/dep-logic: Remove old (diff)
downloadgentoo-f3877091a0bfc53ba1cb3d0a11faabc777a529c5.tar.gz
gentoo-f3877091a0bfc53ba1cb3d0a11faabc777a529c5.tar.bz2
gentoo-f3877091a0bfc53ba1cb3d0a11faabc777a529c5.zip
dev-python/pymdown-extensions: Bump to 10.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pymdown-extensions/Manifest1
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-10.10.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pymdown-extensions/Manifest b/dev-python/pymdown-extensions/Manifest
index 22d06fc25366..114f0705bafb 100644
--- a/dev-python/pymdown-extensions/Manifest
+++ b/dev-python/pymdown-extensions/Manifest
@@ -1,2 +1,3 @@
+DIST pymdown_extensions-10.10.1.tar.gz 828448 BLAKE2B 6db04e72229e53c01f358679025ad94905553aa0eefec37887dd91c83ed4e24efc2be41ac533a981880ff7527b2d592dd7958ea7b49ce623b31b94aff69a63f1 SHA512 731cc26e225af87c75d743abc422e27f93fc0fdf2059411580e63b8344e6ede731e57f20b6679c15a3b84f45432273dce6ad63cacbbeed63ab9c31d8338ccdaa
DIST pymdown_extensions-10.10.tar.gz 828386 BLAKE2B feca952ef46e405215a9ad3365c9afb24bc042590a3ddd87dae7d38a2ba24236463c3ffd7348446c563259246763b969b2c51986a3843d4645ffa530a44cbfb4 SHA512 09aaf7b4ee54bea055816a9f30da04f2cd7e342aa37163805f2eda19554ef93e33c6ef2853ca6b59ae9ae00f5347742c7ea2ba2abe3b5a2de503ec3106320465
DIST pymdown_extensions-10.9.tar.gz 812128 BLAKE2B 2427c41b8587e8b0c4d9bedc4e7c413959545f6c1a12b2c9453861bdb349cbd5bb70327384821f6423718296f56efa17aae21db79bdd038f330246555bcd538b SHA512 3642ccf18a85ffe6ac03dcb132f4b64009490e2a6d0cc70c322ef7640de2a5895a321f755f2d6e16f9c9e84b112c12ded2db18ff73d3201f7b9e0a10c8cd78b5
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-10.10.1.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-10.10.1.ebuild
new file mode 100644
index 000000000000..8447dcb9ba40
--- /dev/null
+++ b/dev-python/pymdown-extensions/pymdown-extensions-10.10.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions for Python Markdown"
+HOMEPAGE="
+ https://github.com/facelessuser/pymdown-extensions/
+ https://pypi.org/project/pymdown-extensions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pygments-2.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}