summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 00:10:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-08 18:49:01 +0100
commit0f6840a9c60112733219a6dd26ded27de61e6cda (patch)
treeae7258af8f8d062769953aadbdecea962b6e0dbe /dev-qt/qtsql/qtsql-5.9.6-r1.ebuild
parentsys-libs/libnih: mark s390 stable (diff)
downloadgentoo-0f6840a9c60112733219a6dd26ded27de61e6cda.tar.gz
gentoo-0f6840a9c60112733219a6dd26ded27de61e6cda.tar.bz2
gentoo-0f6840a9c60112733219a6dd26ded27de61e6cda.zip
dev-qt: Drop Qt 5.9.6
5.11.1 is stable for some time, with 5.11.3 already being prepared. We did not bother to bump 5.9.7 anymore, and there are several sec fixes in these later versions. Depends on app-misc/geoclue:0 to be removed from repo. Does not build against >=OpenSSL-1.1. Does not build against >=ffmpeg-4. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtsql/qtsql-5.9.6-r1.ebuild')
-rw-r--r--dev-qt/qtsql/qtsql-5.9.6-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-qt/qtsql/qtsql-5.9.6-r1.ebuild b/dev-qt/qtsql/qtsql-5.9.6-r1.ebuild
deleted file mode 100644
index c40771bbe943..000000000000
--- a/dev-qt/qtsql/qtsql-5.9.6-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="SQL abstraction library for the Qt5 framework"
-SLOT=5/$(ver_cut 1-3) # bug 639140
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-fbsd"
-fi
-
-IUSE="freetds mysql oci8 odbc postgres +sqlite"
-
-REQUIRED_USE="
- || ( freetds mysql oci8 odbc postgres sqlite )
-"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- freetds? ( dev-db/freetds )
- mysql? ( virtual/libmysqlclient:= )
- oci8? ( dev-db/oracle-instantclient-basic )
- odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( >=dev-db/sqlite-3.8.10.2:3 )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.9.5-mariadb-10.2.patch"
- # See also: https://codereview.qt-project.org/#/c/206850/
-)
-
-QT5_TARGET_SUBDIRS=(
- src/sql
- src/plugins/sqldrivers
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :sql
-)
-
-src_configure() {
- local myconf=(
- $(qt_use freetds sql-tds plugin)
- $(qt_use mysql sql-mysql plugin)
- $(qt_use oci8 sql-oci plugin)
- $(qt_use odbc sql-odbc plugin)
- $(qt_use postgres sql-psql plugin)
- $(qt_use sqlite sql-sqlite plugin)
- $(usex sqlite -system-sqlite '')
- )
-
- use mysql && myconf+=("-I${EPREFIX}/usr/include/mysql" "-L${EPREFIX}/usr/$(get_libdir)/mysql")
- use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
- use odbc && myconf+=("-I${EPREFIX}/usr/include/iodbc")
- use postgres && myconf+=("-I${EPREFIX}/usr/include/postgresql/pgsql")
-
- qt5-build_src_configure
-}