summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-24 02:57:01 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-24 03:23:11 +1000
commit421e93435a836b5245edd3e97a533ab806941e91 (patch)
treed4ef6b3cf40176ce99ac82a1d6f9144532d93842 /dev-qt/qtwayland
parentapp-emulation/qemu-guest-agent: fix build w/newer glibc #580924 (diff)
downloadgentoo-421e93435a836b5245edd3e97a533ab806941e91.tar.gz
gentoo-421e93435a836b5245edd3e97a533ab806941e91.tar.bz2
gentoo-421e93435a836b5245edd3e97a533ab806941e91.zip
dev-qt: version bump 5.6.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/metadata.xml5
-rw-r--r--dev-qt/qtwayland/qtwayland-5.6.0.ebuild41
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index d94ef7949d9f..a5d6e7b785ca 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
DIST qtwayland-opensource-src-5.5.1.tar.xz 259312 SHA256 c3804bdc49a952af0301bbccdb402d8f859044732246f5a12ae8e0f4ae8bdda6 SHA512 27b319abce8fa16bc166fb46eb033200d3f2dda1d15038e0b2da432d186a4444c297e0e5be449513d71fd26f891419f300688b6e130edda601ffdc69d4ab93ed WHIRLPOOL e69d384acf1f7c11f3699c1d42f92b6340184aff5e25388cbbe183e260aa7872aaec92015156f5cc534f0fad63629178073479603e66bc90c6fb1750ca87cf46
+DIST qtwayland-opensource-src-5.6.0.tar.xz 262996 SHA256 b55d0142f245c927970031ef908e98cb20f1d7a2a5441647ed937252fed3bfcc SHA512 aacf86de372033f396986a956519f913741752ffda1418c08e6735e3facc61bf561c78b8d6e4ec9a970f4db473b7e67eb3f619148d381c4d2b17feccb976dadb WHIRLPOOL d0f40cf0385a59ee95284690089c4b15a598b3019b06351d9edcd68098e16e80a3ec9103e2f0517235ded8f0d789caa1aab1a224b51b2d143bef8978dd49a67f
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index b6af4473833c..138dabc2f161 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -14,4 +14,9 @@
<bugs-to>https://bugreports.qt.io/</bugs-to>
<doc>http://doc.qt.io/</doc>
</upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
</pkgmetadata>
diff --git a/dev-qt/qtwayland/qtwayland-5.6.0.ebuild b/dev-qt/qtwayland/qtwayland-5.6.0.ebuild
new file mode 100644
index 000000000000..1039d3d172da
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+IUSE="egl qml wayland-compositor xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.4.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[egl=]
+ media-libs/mesa[egl?]
+ >=x11-libs/libxkbcommon-0.2.0
+ wayland-compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+ )
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ if use wayland-compositor; then
+ echo "CONFIG += wayland-compositor" >> "${QT5_BUILD_DIR}"/.qmake.cache
+ fi
+
+ qt_use_compile_test xcomposite
+ qt_use_disable_mod qml quick src/compositor/compositor_api/compositor_api.pri
+
+ qt5-build_src_configure
+}