summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2023-03-29 23:29:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-04-18 09:03:25 +0300
commit4989398ca8a55f07c018bca35db3abade6391619 (patch)
tree8c8ae927d3139f1c9899a4e05fdc6fa12b84c150 /dev-qt
parentsys-cluster/legion: add 23.03.0 (diff)
downloadgentoo-4989398ca8a55f07c018bca35db3abade6391619.tar.gz
gentoo-4989398ca8a55f07c018bca35db3abade6391619.tar.bz2
gentoo-4989398ca8a55f07c018bca35db3abade6391619.zip
dev-qt/qtscxml: add 6.5.0
Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index beb1c1313b49..043bd9c12785 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-opensource-src-5.15.8.tar.xz 436864 BLAKE2B ada2ac54eaef077da132929a658a461151e5b1c15a02874b80da6334eb5fdca5737126e5caff308fccd0bec96cd07a36b188113b8d26beb7dab9d1e9278598e8 SHA512 f1e560e3091eb60b70e5b7ab187511708d16c1b2e8a0c1a6d7a95358eb3ed998bdf0e57b7855e38a773509805790603e3e8e64627f52f05f305d8a29108db9f2
DIST qtscxml-everywhere-opensource-src-5.15.9.tar.xz 436620 BLAKE2B 4471906e193e71c2cf16165a6925f2fa802d057afcb2690b0e9558c4fa98445282660346364800357e37f1146e077a3b10043fba3bd934bee34d8b801c74214e SHA512 f6c6bdcb651055fd3a9b18fae1860f0d72afe83a08b387cb1393d0b1966eaaf1d8ce4530e6faa3a4e4a18d97a8e36937303b99e29d7dba17b6bcda61a5eb9872
+DIST qtscxml-everywhere-src-6.5.0.tar.xz 1254984 BLAKE2B c004f2bb8961c2d8678497363920b7be82917b9b178334db90ef4ec386d498f7bbc4976018f0dbf35f76f7b7b5aea972b785f51bf60d91d29b5c7585dc18171e SHA512 21933952c5eecce2cfe45c8c7b50d249b71f49538ee6736a7180534abd44b6032ea9e4d2aa9b658b78f60ffd61cd065046da6df5abed13483237e8d8dcd9fe56
diff --git a/dev-qt/qtscxml/qtscxml-6.5.0.ebuild b/dev-qt/qtscxml/qtscxml-6.5.0.ebuild
new file mode 100644
index 000000000000..1016e87c11b7
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="
+ ${DEPEND}
+"