summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-18 07:21:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-18 14:13:51 -0400
commit9c4b61974ba08b76a8383f7cc2ebcaa94d18d86c (patch)
treec7a648006a120df6bf1055c3863b8c6a551d855d /dev-qt
parentdev-qt/qtwayland: add 6.7.2 (diff)
downloadgentoo-9c4b61974ba08b76a8383f7cc2ebcaa94d18d86c.tar.gz
gentoo-9c4b61974ba08b76a8383f7cc2ebcaa94d18d86c.tar.bz2
gentoo-9c4b61974ba08b76a8383f7cc2ebcaa94d18d86c.zip
dev-qt/qtwayland: skip 3 tests for wayland-1.23 for now
Originally thought it was a 6.7.2 regression but 6.7.1 fails as well. Already been reported upstream and there's no need for this to block bumping/stabilizing 6.7.2 meanwhile. At the moment no reported runtime issues, so not going to set a upper bound either. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/qtwayland-6.7.1.ebuild6
-rw-r--r--dev-qt/qtwayland/qtwayland-6.7.2.ebuild6
-rw-r--r--dev-qt/qtwayland/qtwayland-6.8.9999.ebuild6
-rw-r--r--dev-qt/qtwayland/qtwayland-6.9999.ebuild6
4 files changed, 24 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/qtwayland-6.7.1.ebuild b/dev-qt/qtwayland/qtwayland-6.7.1.ebuild
index e9e5a4004120..930d08222fb3 100644
--- a/dev-qt/qtwayland/qtwayland-6.7.1.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.7.1.ebuild
@@ -35,6 +35,12 @@ CMAKE_SKIP_TESTS=(
# needs a compositor/opengl, skip the extra trouble
tst_surface
tst_xdgdecorationv1
+ # known failing with wayland-1.23.0 (or at least with offscreen), not
+ # believed to result in critical runtime issues so skip until this is
+ # looked at upstream (https://bugreports.qt.io/browse/QTBUG-126379)
+ tst_client
+ tst_compositor
+ tst_scaling
)
src_configure() {
diff --git a/dev-qt/qtwayland/qtwayland-6.7.2.ebuild b/dev-qt/qtwayland/qtwayland-6.7.2.ebuild
index dc3ce8575fd3..11f94d7bd709 100644
--- a/dev-qt/qtwayland/qtwayland-6.7.2.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.7.2.ebuild
@@ -35,6 +35,12 @@ CMAKE_SKIP_TESTS=(
# needs a compositor/opengl, skip the extra trouble
tst_surface
tst_xdgdecorationv1
+ # known failing with wayland-1.23.0 (or at least with offscreen), not
+ # believed to result in critical runtime issues so skip until this is
+ # looked at upstream (https://bugreports.qt.io/browse/QTBUG-126379)
+ tst_client
+ tst_compositor
+ tst_scaling
)
src_configure() {
diff --git a/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild
index 93ba392322f1..cb3c8f5542c4 100644
--- a/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.8.9999.ebuild
@@ -39,6 +39,12 @@ CMAKE_SKIP_TESTS=(
# needs a compositor/opengl, skip the extra trouble
tst_surface
tst_xdgdecorationv1
+ # known failing with wayland-1.23.0 (or at least with offscreen), not
+ # believed to result in critical runtime issues so skip until this is
+ # looked at upstream (https://bugreports.qt.io/browse/QTBUG-126379)
+ tst_client
+ tst_compositor
+ tst_scaling
)
src_configure() {
diff --git a/dev-qt/qtwayland/qtwayland-6.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
index 93ba392322f1..cb3c8f5542c4 100644
--- a/dev-qt/qtwayland/qtwayland-6.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
@@ -39,6 +39,12 @@ CMAKE_SKIP_TESTS=(
# needs a compositor/opengl, skip the extra trouble
tst_surface
tst_xdgdecorationv1
+ # known failing with wayland-1.23.0 (or at least with offscreen), not
+ # believed to result in critical runtime issues so skip until this is
+ # looked at upstream (https://bugreports.qt.io/browse/QTBUG-126379)
+ tst_client
+ tst_compositor
+ tst_scaling
)
src_configure() {