summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-18 05:25:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-18 14:13:49 -0400
commita26f81ee72d5f25baf50da3c505c01565f5f58a5 (patch)
tree3ff72196c33eb9ae628ca21db651701b5a896924 /dev-qt
parentdev-qt/qtquicktimeline: add 6.7.2 (diff)
downloadgentoo-a26f81ee72d5f25baf50da3c505c01565f5f58a5.tar.gz
gentoo-a26f81ee72d5f25baf50da3c505c01565f5f58a5.tar.bz2
gentoo-a26f81ee72d5f25baf50da3c505c01565f5f58a5.zip
dev-qt/qtscxml: add 6.7.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.7.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index d0b2ceb7384f..0663ef7e2e20 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-opensource-src-5.15.14.tar.xz 429224 BLAKE2B 67936258bfb67bddf5b711bc97bebb123f56d8f7dca9b46424a33d1205b0a3a6dfc89ae7bc429ffedb928d4f1b88c62abdabee301c09a0e3b0bf65128f174d67 SHA512 1490824b0108300b1924f404431e3871ce067def15993aed9af768c871b3d0eae4cd0b8f467671d3ebcada98d5e11dfe86e250467b7dbf9708ce9f37766861d5
DIST qtscxml-everywhere-src-6.7.1.tar.xz 1168276 BLAKE2B e97d521ce1c239c4c6dc40c44fed2f158e27df596df552fc8c296ce2824bca904a031303907ee2d8ec8d1cbc96c7b0d0ea384044e6a8cd1a31965ffab4e6bf3b SHA512 64a3fe0fb4311b4531c6fa9576399a181456990882c9aa7a5ddd5567cef579a22978e87d1641aa61532ef7c482b188967a401d7fd3b1cdf0f3ff657927594c61
+DIST qtscxml-everywhere-src-6.7.2.tar.xz 1168452 BLAKE2B 7cb06fd09758aaea28ccada62aa51b427c265416afa3f152601cadd1c9586050e87d36f8cf9679ca3ef83777bfec1119d861bd9491a176460d58beb5376e4ce4 SHA512 4eba366c2c10593cfc0fdeeff92aa9951b838837cacf113bf849b5da68da4d41d550490bc4be28620f766ab412ca4066c71ee7a1ff18651dd08267b01df6c2fe
diff --git a/dev-qt/qtscxml/qtscxml-6.7.2.ebuild b/dev-qt/qtscxml/qtscxml-6.7.2.ebuild
new file mode 100644
index 000000000000..70bce441eda7
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}