summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 12:53:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:21 +0200
commit38b64dc253508485d78ca46fb7b7482cb72669a0 (patch)
tree79ed52b1662f8f7139a9425b6c84a5421944c2a1 /dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild
parentdev-ros/diagnostic_aggregator: Bump to 1.9.4. (diff)
downloadgentoo-38b64dc253508485d78ca46fb7b7482cb72669a0.tar.gz
gentoo-38b64dc253508485d78ca46fb7b7482cb72669a0.tar.bz2
gentoo-38b64dc253508485d78ca46fb7b7482cb72669a0.zip
dev-ros/diagnostic_analysis: Bump to 1.9.4.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild')
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild
new file mode 100644
index 000000000000..ffb0ad5ab0b2
--- /dev/null
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts diagnostics data into a series of CSV files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"