summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-12 18:43:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-12 18:58:16 +0200
commit8d8bb695104489ab4e70cb018b95f756b2038a91 (patch)
tree3bfbebbbc951ff51289e3af41513b23043abd6c1 /dev-ros/geodesy/geodesy-0.5.6-r1.ebuild
parentdev-ros/gazebo_plugins: add slot dep on angles (diff)
downloadgentoo-8d8bb695104489ab4e70cb018b95f756b2038a91.tar.gz
gentoo-8d8bb695104489ab4e70cb018b95f756b2038a91.tar.bz2
gentoo-8d8bb695104489ab4e70cb018b95f756b2038a91.zip
dev-ros/geodesy: add slot dep on angles
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/geodesy/geodesy-0.5.6-r1.ebuild')
-rw-r--r--dev-ros/geodesy/geodesy-0.5.6-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/geodesy/geodesy-0.5.6-r1.ebuild b/dev-ros/geodesy/geodesy-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..291dd8ef6a56
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-0.5.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles:0
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/py3.patch" )