summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 17:14:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 11:41:58 +0100
commit78109cec0f3137cae8daffd69cf88c513b24a066 (patch)
tree505dfe6e0831f7eeebbfc17392133bb6b2338add /dev-ros/pcl_conversions/pcl_conversions-1.7.0.ebuild
parentdev-libs/libgit2: amd64 stable wrt bug #702522 (diff)
downloadgentoo-78109cec0f3137cae8daffd69cf88c513b24a066.tar.gz
gentoo-78109cec0f3137cae8daffd69cf88c513b24a066.tar.bz2
gentoo-78109cec0f3137cae8daffd69cf88c513b24a066.zip
dev-ros/pcl_conversions: Bump to 1.7.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/pcl_conversions/pcl_conversions-1.7.0.ebuild')
-rw-r--r--dev-ros/pcl_conversions/pcl_conversions-1.7.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/pcl_conversions/pcl_conversions-1.7.0.ebuild b/dev-ros/pcl_conversions/pcl_conversions-1.7.0.ebuild
new file mode 100644
index 000000000000..84ff87429a51
--- /dev/null
+++ b/dev-ros/pcl_conversions/pcl_conversions-1.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides conversions from PCL data types and ROS message types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ sci-libs/pcl:=
+ dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"