summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:04:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:49 +0200
commitf8953a64dbb3e13a7f54610a2c63438ae6c38186 (patch)
tree3a93bb71be411429723521be2d8d6f8f48b0f521 /dev-ros/rosgraph/rosgraph-1.14.2.ebuild
parentdev-ros/rosbag_storage: Bump to 1.14.2. (diff)
downloadgentoo-f8953a64dbb3e13a7f54610a2c63438ae6c38186.tar.gz
gentoo-f8953a64dbb3e13a7f54610a2c63438ae6c38186.tar.bz2
gentoo-f8953a64dbb3e13a7f54610a2c63438ae6c38186.zip
dev-ros/rosgraph: Bump to 1.14.2.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.14.2.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.14.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.14.2.ebuild b/dev-ros/rosgraph/rosgraph-1.14.2.ebuild
new file mode 100644
index 000000000000..85373fac5957
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.14.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"