summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 09:59:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:51 +0100
commite945f17ade9206d01685cd0ef73283383d32d1b6 (patch)
tree080346048b4943e3f439dec1f0fda8e39dcf0e72 /dev-ros/rostopic/rostopic-1.13.0.ebuild
parentdev-ros/rostest: Bump to 1.13.0. (diff)
downloadgentoo-e945f17ade9206d01685cd0ef73283383d32d1b6.tar.gz
gentoo-e945f17ade9206d01685cd0ef73283383d32d1b6.tar.bz2
gentoo-e945f17ade9206d01685cd0ef73283383d32d1b6.zip
dev-ros/rostopic: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.13.0.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.13.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.13.0.ebuild b/dev-ros/rostopic/rostopic-1.13.0.ebuild
new file mode 100644
index 000000000000..bdc4c82605e8
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"