summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 12:20:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:51 +0100
commite83a9211a4011102af0257b50b0fea3b18a41ba0 (patch)
tree1e2424b72ad0da72a3e95633a107e523b6db6f8a /dev-ros/rqt_gui
parentdev-python/rospkg: remove old (diff)
downloadgentoo-e83a9211a4011102af0257b50b0fea3b18a41ba0.tar.gz
gentoo-e83a9211a4011102af0257b50b0fea3b18a41ba0.tar.bz2
gentoo-e83a9211a4011102af0257b50b0fea3b18a41ba0.zip
dev-ros/rqt_gui: Strip ros_packages/ from plugin.xml search path
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_gui')
-rw-r--r--dev-ros/rqt_gui/files/gentoo.patch15
-rw-r--r--dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild21
-rw-r--r--dev-ros/rqt_gui/rqt_gui-9999.ebuild1
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui/files/gentoo.patch b/dev-ros/rqt_gui/files/gentoo.patch
new file mode 100644
index 000000000000..abdc30a8ccbd
--- /dev/null
+++ b/dev-ros/rqt_gui/files/gentoo.patch
@@ -0,0 +1,15 @@
+Index: rqt_gui/src/rqt_gui/ros_plugin_provider.py
+===================================================================
+--- rqt_gui.orig/src/rqt_gui/ros_plugin_provider.py
++++ rqt_gui/src/rqt_gui/ros_plugin_provider.py
+@@ -109,6 +109,10 @@ class RosPluginProvider(PluginProvider):
+ def _parse_plugin_xml(self, package_name, plugin_xml):
+ plugin_descriptors = []
+
++ # Gentoo: strip ros_packages to get the real path.
++ if not os.path.isfile(plugin_xml):
++ plugin_xml = plugin_xml.replace('ros_packages/', '')
++
+ if not os.path.isfile(plugin_xml):
+ qCritical('RosPluginProvider._parse_plugin_xml() plugin file "%s" in package "%s" not found' % (plugin_xml, package_name))
+ return plugin_descriptors
diff --git a/dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild b/dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..1ba3c35e10d0
--- /dev/null
+++ b/dev-ros/rqt_gui/rqt_gui-0.3.2-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the ROS integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
diff --git a/dev-ros/rqt_gui/rqt_gui-9999.ebuild b/dev-ros/rqt_gui/rqt_gui-9999.ebuild
index 8d01cc5e183e..1ba3c35e10d0 100644
--- a/dev-ros/rqt_gui/rqt_gui-9999.ebuild
+++ b/dev-ros/rqt_gui/rqt_gui-9999.ebuild
@@ -18,3 +18,4 @@ IUSE=""
RDEPEND=">=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )