summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-03 17:06:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-03 17:12:43 +0100
commit22c4ccf953f372d90f5afc871bf6ba1a8d2c7dbc (patch)
treef53ebe7d5c4b83a476244ac150e449e291c8b0dc /dev-ros/test_tf2/test_tf2-0.6.5.ebuild
parentdev-python/catkin_pkg: bump to 0.4.9 (diff)
downloadgentoo-22c4ccf953f372d90f5afc871bf6ba1a8d2c7dbc.tar.gz
gentoo-22c4ccf953f372d90f5afc871bf6ba1a8d2c7dbc.tar.bz2
gentoo-22c4ccf953f372d90f5afc871bf6ba1a8d2c7dbc.zip
dev-ros/test_tf2: Bump to 0.6.5.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-0.6.5.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.6.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.6.5.ebuild b/dev-ros/test_tf2/test_tf2-0.6.5.ebuild
new file mode 100644
index 000000000000..3393b751c864
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.6.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_msgs
+ sci-libs/orocos_kdl
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )