summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 11:51:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 12:45:53 +0200
commitd7f2c62a0274565b39b78c8e7d5c9aabe47ead51 (patch)
treec138a6d7e0847f121b98f48403f49a774b540eb5 /dev-ros
parentdev-ros/kdl_conversions: Bump to 1.13.2. (diff)
downloadgentoo-d7f2c62a0274565b39b78c8e7d5c9aabe47ead51.tar.gz
gentoo-d7f2c62a0274565b39b78c8e7d5c9aabe47ead51.tar.bz2
gentoo-d7f2c62a0274565b39b78c8e7d5c9aabe47ead51.zip
dev-ros/tf: Bump to 1.13.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf/Manifest1
-rw-r--r--dev-ros/tf/tf-1.13.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/tf/Manifest b/dev-ros/tf/Manifest
index 11ef47628238..6324270943e0 100644
--- a/dev-ros/tf/Manifest
+++ b/dev-ros/tf/Manifest
@@ -1 +1,2 @@
DIST geometry-1.12.0.tar.gz 186357 BLAKE2B 6bf8c93b5707403655253a30b8994bb62b8b44077805bf43b266b781e5c8edb65c402d00fb76d9e87bd111211b932f10487f769ac4d04322255b57f44680adca SHA512 5cef17a76dfd5b9c2f118519bf3a74a1213d3036c8de19de453e8419d12d744a6a4ae4fd4a76b34c455b548a9857cd5bfa181698d903356737e1555d619a0627
+DIST geometry-1.13.2.tar.gz 188225 BLAKE2B b08e78b298c94c38baa5d25a878be703d7d3a310277b66690b9fe4da1d0cd3f9083cf3bf6dc1d59149599b6fb0ec10feaf668206da245ed7e0cb9cf1878b620c SHA512 504de0e7ebf1dd73e918ab4fa39967cc9e39a53d487072430106b391d669ddfc7e530b66b38f4f73d1787e4a73acdad8e707c6757afe2e235157d4aa19f28af2
diff --git a/dev-ros/tf/tf-1.13.2.ebuild b/dev-ros/tf/tf-1.13.2.ebuild
new file mode 100644
index 000000000000..4892a757b466
--- /dev/null
+++ b/dev-ros/tf/tf-1.13.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/angles
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"