summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-13 07:42:14 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-13 07:42:14 +0100
commit03c699e97e3f7310d09b95a825c7bb6733976016 (patch)
tree6c34a579de1aa99ffd0047fbaf9db61d34f7ae89 /dev-ruby/activejob/activejob-5.1.6.ebuild
parentdev-ruby/actionview: cleanup (diff)
downloadgentoo-03c699e97e3f7310d09b95a825c7bb6733976016.tar.gz
gentoo-03c699e97e3f7310d09b95a825c7bb6733976016.tar.bz2
gentoo-03c699e97e3f7310d09b95a825c7bb6733976016.zip
dev-ruby/activejob: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/activejob/activejob-5.1.6.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-5.1.6.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-ruby/activejob/activejob-5.1.6.ebuild b/dev-ruby/activejob/activejob-5.1.6.ebuild
deleted file mode 100644
index 16102b24c9da..000000000000
--- a/dev-ruby/activejob/activejob-5.1.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Job framework with pluggable queues"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/globalid-0.3.6
-"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/mocha-0.14.0:0.14
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
-
- # Remove all currently unpackaged queues.
- sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' Rakefile || die
-}