summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/cri
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/cri')
-rw-r--r--dev-ruby/cri/Manifest3
-rw-r--r--dev-ruby/cri/cri-2.4.1.ebuild25
-rw-r--r--dev-ruby/cri/cri-2.6.1.ebuild31
-rw-r--r--dev-ruby/cri/cri-2.7.0.ebuild34
-rw-r--r--dev-ruby/cri/metadata.xml5
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-ruby/cri/Manifest b/dev-ruby/cri/Manifest
new file mode 100644
index 000000000000..2f65da86f451
--- /dev/null
+++ b/dev-ruby/cri/Manifest
@@ -0,0 +1,3 @@
+DIST cri-2.4.1.gem 20480 SHA256 1c736c7e4fb080e916af10fccbfd8dab39224126db31377ddc9048ea8f2a8070 SHA512 57ca21cdad59fcff78cdb042be3614f977ed0b5ad2f42e2b2f42df3eac6656fac2b6a33fe0af1ac511cce9db0f1345403f0846899353d156a7c28efdc43e8d4a WHIRLPOOL bffe0f9b371feee542556e177be0e645b4804dcb58bc2ee0aa7d5ee1dad23d3e6b6c1c9fe2ed0edb0ae20b33361eb518cf661d1bdab871c4038fd4a1ceed5369
+DIST cri-2.6.1.gem 23552 SHA256 349dedff69722138ea49b69f32e2195094b4e2300caf230b33bdd29c3fdffc7f SHA512 61ccbbc34e58ca7473817beccc7e2af29ab48981d58ddb4d753e32c98ae933acc33e696d922d3f3fc4adfa3f2ee230a7d2eb27bd671f2b46dfda72ad9ab15e55 WHIRLPOOL a45affae09c29318d0ef59604923f37369cc9af1c51d56ca58b9d8391797c22ebeef703e87d50d7d9cf1a4eb742241591503bc4491d312b9ecc050235c66599a
+DIST cri-2.7.0.gem 25088 SHA256 861e637cfeb0f8a618ea982f675c574520590aecbd098a2cf3d8be339ff3ed62 SHA512 4bef9bbe623b45f21b0cc66aba40ac3fd945227fb50a6b169c79b8ac9b84144119defaaed3a76044b15a916d077fa91f36c35fa22b69b7405f6c9b4fb8bf1118 WHIRLPOOL bf77d0570902a374198cd59d2f19e4da274fd1f76f1a2783ed22572ef52540812d1d9c53c783524fcbd074af0bc9f368ef387f40ab10149b9b97feb32db0d88b
diff --git a/dev-ruby/cri/cri-2.4.1.ebuild b/dev-ruby/cri/cri-2.4.1.ebuild
new file mode 100644
index 000000000000..dc3a7404e9a1
--- /dev/null
+++ b/dev-ruby/cri/cri-2.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Cri is a library for building easy-to-use commandline tools"
+HOMEPAGE="http://rubygems.org/gems/cri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/colored-1.2"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/yard dev-ruby/minitest )"
diff --git a/dev-ruby/cri/cri-2.6.1.ebuild b/dev-ruby/cri/cri-2.6.1.ebuild
new file mode 100644
index 000000000000..e19179bb456b
--- /dev/null
+++ b/dev-ruby/cri/cri-2.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.adoc"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Cri is a library for building easy-to-use commandline tools"
+HOMEPAGE="http://rubygems.org/gems/cri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/colored-1.2"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/yard dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -e '/coveralls/I s:^:#:' -i test/helper.rb || die
+}
diff --git a/dev-ruby/cri/cri-2.7.0.ebuild b/dev-ruby/cri/cri-2.7.0.ebuild
new file mode 100644
index 000000000000..9d14b0694e09
--- /dev/null
+++ b/dev-ruby/cri/cri-2.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.adoc"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Cri is a library for building easy-to-use commandline tools"
+HOMEPAGE="http://rubygems.org/gems/cri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/colored-1.2"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/yard dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -e '/coveralls/I s:^:#:' -i test/helper.rb || die
+ sed -i -e '/rubocop/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rake test_unit || die
+}
diff --git a/dev-ruby/cri/metadata.xml b/dev-ruby/cri/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/cri/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>