summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-31 00:12:31 +0100
committerSam James <sam@gentoo.org>2023-03-31 01:50:52 +0100
commit895accf87eca1fa89f8177585f8f67515b20986d (patch)
tree4bdca7a4f34c0f91b58062e78fdb67c53293d8ee /dev-ruby/mimemagic
parentdev-ruby/omniauth: drop 2.1.0 (diff)
downloadgentoo-895accf87eca1fa89f8177585f8f67515b20986d.tar.gz
gentoo-895accf87eca1fa89f8177585f8f67515b20986d.tar.bz2
gentoo-895accf87eca1fa89f8177585f8f67515b20986d.zip
dev-ruby/mimemagic: drop 0.3.10, 0.4.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/mimemagic')
-rw-r--r--dev-ruby/mimemagic/mimemagic-0.3.10.ebuild36
-rw-r--r--dev-ruby/mimemagic/mimemagic-0.4.3.ebuild40
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-ruby/mimemagic/mimemagic-0.3.10.ebuild b/dev-ruby/mimemagic/mimemagic-0.3.10.ebuild
deleted file mode 100644
index 95b97506ad87..000000000000
--- a/dev-ruby/mimemagic/mimemagic-0.3.10.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC=mimemagic.gemspec
-
-inherit prefix ruby-fakegem
-
-DESCRIPTION="Fast mime detection by extension or content"
-HOMEPAGE="https://github.com/mimemagicrb/mimemagic"
-SRC_URI="https://github.com/mimemagicrb/mimemagic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND+=" x11-misc/shared-mime-info"
-
-ruby_add_rdepend "
- dev-ruby/nokogiri
- dev-ruby/rake
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- cp "${FILESDIR}/${PN}-0.3.9-path.rb" lib/mimemagic/path.rb || die
- eprefixify lib/mimemagic/path.rb
-
- sed -i -e 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
diff --git a/dev-ruby/mimemagic/mimemagic-0.4.3.ebuild b/dev-ruby/mimemagic/mimemagic-0.4.3.ebuild
deleted file mode 100644
index d8b4ab4e72fa..000000000000
--- a/dev-ruby/mimemagic/mimemagic-0.4.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC=mimemagic.gemspec
-
-inherit prefix ruby-fakegem
-
-DESCRIPTION="Fast mime detection by extension or content"
-HOMEPAGE="https://github.com/mimemagicrb/mimemagic"
-SRC_URI="https://github.com/mimemagicrb/mimemagic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND+=" x11-misc/shared-mime-info"
-
-ruby_add_rdepend "
- dev-ruby/nokogiri
- dev-ruby/rake
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- cp "${FILESDIR}/${PN}-0.3.9-path.rb" lib/mimemagic/path.rb || die
- eprefixify lib/mimemagic/path.rb
-
- sed -i -e 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/**/*_test.rb"].each {|f| require f}' || die
-}