summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-22 14:03:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-22 14:03:28 -0500
commit345bca2d2292341a62e09ce0b873f66ec4eb1e40 (patch)
treeea23ea15f093b7ba960dcd7157b246d019a4fd64 /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: 6.13.0 bump (diff)
downloadgentoo-345bca2d2292341a62e09ce0b873f66ec4eb1e40.tar.gz
gentoo-345bca2d2292341a62e09ce0b873f66ec4eb1e40.tar.bz2
gentoo-345bca2d2292341a62e09ce0b873f66ec4eb1e40.zip
dev-ruby/puppetdb-termini: 6.13.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.13.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index ffbcc32fc7fc..084a80390450 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1 +1,2 @@
DIST puppetdb-termini_6.12.0-1stretch_all.deb 21290 BLAKE2B 11bc0a316517190162e7e4e5a2ce05bc880ef8412bfcf5fb66ec68545bd7779e217d5d5e75ab79f24fc6b2f68e1a962262704efb8833fdce84288d060245b898 SHA512 a742825e9f9bacf5726814474b7812393d1a51c50fd710d771c10a9e23c874a465c6859fc17485b66a2c4114ac170f2f25c5ce1be6684ff18f5da31dc9ef0744
+DIST puppetdb-termini_6.13.0-1stretch_all.deb 21296 BLAKE2B 6ef6f82047f293b854e1b0d6db2933e18bc922225d1bb7fe4a3d03d2dbe5da00cdb68e7e3ac35097f466ee21de5a7ed584606684a52c088a9e31abe9fe11d7cf SHA512 bbcf8d2ed996925ead0add6899b266ca9308b01cc12d0dfa6f61956e801a092abf5a01ae4647bf96778f9fe0fa95e17bfae0a3b30576346093651141c1982ebf
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.13.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.13.0.ebuild
new file mode 100644
index 000000000000..a7f2b53b2dde
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}