summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-04-07 10:23:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-04-07 10:23:06 -0500
commitd1f2ebb4bd27298acab70215c6435e0a9786a9b3 (patch)
tree2ea936e48c494e5af74a8428fb5e854f4febe8da /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: add 7.13.0 (diff)
downloadgentoo-d1f2ebb4bd27298acab70215c6435e0a9786a9b3.tar.gz
gentoo-d1f2ebb4bd27298acab70215c6435e0a9786a9b3.tar.bz2
gentoo-d1f2ebb4bd27298acab70215c6435e0a9786a9b3.zip
dev-ruby/puppetdb-termini: add 7.13.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 47bc76277f2f..1f518819652d 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.11.1-1stretch_all.deb 22652 BLAKE2B 776f7254062c4864236236101e79a8010ecc83a468c8b6dd14d005c4045fc695494cbe7fd468ad642bb6a13d3f8578db3c5a92981e03a21d4622a1ef5a9fc106 SHA512 5c2f6279f5ed8cdb6401a9b87f9c8e2459f1c5e1b4327224b5db9b9349ae4c20ed3237cc0e0a5aa4cf89763296cc9198cbfd33780fad224bbbaf0e11cbb29e97
DIST puppetdb-termini_7.12.1-1bullseye_all.deb 22644 BLAKE2B 16c62aafca8ea2a1f04e6e3708bd1354262dcfdc2afd085e4ef2c949409e4ed9a21fb965b9b67099024d9027b996bdbbc3bf16bbdf92f6cfa6e8d0b4b7c60c90 SHA512 4fd214c02e71a038ba52b2cc2ad33172ab5a13739e831fa1f53fbba45b7f19644104fe06cd12c796eb81556dcf9c5221cd9341d55a4b803c5d005f1da4deca46
+DIST puppetdb-termini_7.13.0-1bullseye_all.deb 22548 BLAKE2B 535a3f846a7a10dcfaec4447ae852c6c4d870a573169f84e31f61c361164caea989f911df2d18e183c391dd0130a10b9422057eecaab304bebbb022f78e22a21 SHA512 3c8e440bfc55579d0c9a03ecae516d4cef49512ad9fdd6fceef37618c163ecac6d77a2b17b6cbb7131ceb3787904486bb78eef84a36a5f76672918db6d30db86
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild
new file mode 100644
index 000000000000..21001dc94028
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/bullseye/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1bullseye_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}