summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-07 18:21:13 +0100
committerSam James <sam@gentoo.org>2023-04-07 19:09:46 +0100
commit6bf971ece49a09adde769ff71c72b1fb92b5e0f9 (patch)
treecc6d38c6613dd23caef703794d090a665e53dac6 /dev-ruby/rails
parentdev-ruby/actionmailbox: enable ruby32 for 7.0.x (diff)
downloadgentoo-6bf971ece49a09adde769ff71c72b1fb92b5e0f9.tar.gz
gentoo-6bf971ece49a09adde769ff71c72b1fb92b5e0f9.tar.bz2
gentoo-6bf971ece49a09adde769ff71c72b1fb92b5e0f9.zip
dev-ruby/rails: enable ruby32 for 7.0.x
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/rails-7.0.4.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/rails/rails-7.0.4.3-r1.ebuild b/dev-ruby/rails/rails-7.0.4.3-r1.ebuild
new file mode 100644
index 000000000000..add92a951b63
--- /dev/null
+++ b/dev-ruby/rails/rails-7.0.4.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistence framework"
+HOMEPAGE="https://rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_rdepend "
+ ~dev-ruby/actioncable-${PV}
+ ~dev-ruby/actionmailbox-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actiontext-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/bundler-1.15.0:*
+ >=dev-ruby/sprockets-rails-2.0.0:*
+"