summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-14 23:36:51 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-14 23:37:20 +0100
commitd544b4ff6bdaea87d68bc824c2b20c3c8ee1c3a5 (patch)
tree9e281d17adb82672fc879520613dfa63431b4db1 /dev-ruby/rbpdf-font/rbpdf-font-1.19.0.ebuild
parentx11-terms/roxterm: Fix proxy-maintainers herd name (diff)
downloadgentoo-d544b4ff6bdaea87d68bc824c2b20c3c8ee1c3a5.tar.gz
gentoo-d544b4ff6bdaea87d68bc824c2b20c3c8ee1c3a5.tar.bz2
gentoo-d544b4ff6bdaea87d68bc824c2b20c3c8ee1c3a5.zip
dev-ruby/rbpdf-font: Initial version
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/rbpdf-font/rbpdf-font-1.19.0.ebuild')
-rw-r--r--dev-ruby/rbpdf-font/rbpdf-font-1.19.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rbpdf-font/rbpdf-font-1.19.0.ebuild b/dev-ruby/rbpdf-font/rbpdf-font-1.19.0.ebuild
new file mode 100644
index 000000000000..714be2242b57
--- /dev/null
+++ b/dev-ruby/rbpdf-font/rbpdf-font-1.19.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 support waiting on dev-ruby/action{pack,view}.
+USE_RUBY="ruby20 ruby21"
+
+# Avoid the complexity of the "rake" recipe and run the tests manually.
+#RUBY_FAKEGEM_RECIPE_TEST=none
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails RBPDF plugin"
+HOMEPAGE="https://github.com/naitoh/rbpdf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+}
+
+RESTRICT="test"