summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-29 11:18:46 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-29 11:41:54 +0200
commitf335c8b05e861967fe4f66fcff22bb463d2ace54 (patch)
tree7d78799bc57177d1a07038c77b35b1d1cbd46652 /dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
parentdev-ruby/rex-encoder: add ruby24, ruby25 (diff)
downloadgentoo-f335c8b05e861967fe4f66fcff22bb463d2ace54.tar.gz
gentoo-f335c8b05e861967fe4f66fcff22bb463d2ace54.tar.bz2
gentoo-f335c8b05e861967fe4f66fcff22bb463d2ace54.zip
dev-ruby/rex-exploitation: add 0.1.19
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild')
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
new file mode 100644
index 000000000000..58d9ec259d80
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/jsobfu:*
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}