summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-03-05 08:39:29 +0100
committerHans de Graaff <graaff@gentoo.org>2016-03-05 08:39:29 +0100
commitcccb23033765bc684754f22dc5efd8384a9772bd (patch)
tree9a7e96c1592f84b796701b0fdcb680f41efdcc94 /dev-ruby/ruby-ldap
parentdev-ruby/rake-compiler: depend on correct rspec slot (diff)
downloadgentoo-cccb23033765bc684754f22dc5efd8384a9772bd.tar.gz
gentoo-cccb23033765bc684754f22dc5efd8384a9772bd.tar.bz2
gentoo-cccb23033765bc684754f22dc5efd8384a9772bd.zip
dev-ruby/ruby-ldap: add 0.9.18
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/Manifest1
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.18.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/Manifest b/dev-ruby/ruby-ldap/Manifest
index 37b0ca5fd4bd..bd94fba8dbe6 100644
--- a/dev-ruby/ruby-ldap/Manifest
+++ b/dev-ruby/ruby-ldap/Manifest
@@ -1,2 +1,3 @@
DIST ruby-ldap-0.9.16.gem 65024 SHA256 a068e0b0d52621c2a72583e07211f4795b3cd9496dd6b5cf7a2c8a746018ce21 SHA512 b81a9b24f29a7c40b5d1c020008bfd14666a15c3b407e5495ac7b12e470783d696c8ad25c9a508b9933829695a8ac3fcb52a209fdb4fb7de499308af61a4b832 WHIRLPOOL dea6d8f4c716f3c0408ca2ba11e4fd411916f9afd07a497deb91fe38c2f0440482a893527b8976801a41742da15f3cacc7330c85a26ec1c948e49e0a99a1f432
DIST ruby-ldap-0.9.17.gem 66560 SHA256 951ab18e8dbc2b9791555c38833df07e322992d3eb53aefca88a085fc55686c6 SHA512 b6400faa4ae19f3d783810a6b2f7af36e89cbf001aa48a343e1ff6e5f9e74639bb84db2dc58a1465f91130248eaf17767a6c125e1d416aaf7d45ff8c14c3b68e WHIRLPOOL 00b9f4508a94b0c4ecb61e3f3749142b2daa4645d80feccd86d7ed1ff9163a2cc5dcec9d516ebd4b8587573e49abdeadc31427b09e057494f8389b35009ced49
+DIST ruby-ldap-0.9.18.gem 67072 SHA256 cf96420e778dade4851234a3be3b3ffd96a7c3f91a266b4fd60022a14883c5d5 SHA512 698375840498e3cbe6e4ad962b3754bf74b0e0c356f95e59a71267841014a31dc85235e736c2ecd23e86c1ae0f9da00074c1612427afea1b409f0d8e7f596a07 WHIRLPOOL 69f1ec1a6e97eb9d016f62a4be348b1c586d90c38aaad6207177ad8beaf791adee5c6f0a80b7ef1ff0e7a356825f081370929c2a45180303fe612066f66a0efd
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.18.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.18.ebuild
new file mode 100644
index 000000000000..aa8cf8f6457b
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
+ sed -i -e 's:-Wl,--no-undefined::' \
+ -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1
+ cp ldap$(get_modname) lib/ || die
+}