summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-11 08:16:51 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-11 08:52:36 +0200
commit99f9eac03ba8a84239aee8f27aebb91975cee191 (patch)
treec6c7286b7231987cd9d6723440c7e7e202399a1f /dev-ruby/shotgun/shotgun-0.9.2.ebuild
parentdev-ruby/shotgun: cleanup (diff)
downloadgentoo-99f9eac03ba8a84239aee8f27aebb91975cee191.tar.gz
gentoo-99f9eac03ba8a84239aee8f27aebb91975cee191.tar.bz2
gentoo-99f9eac03ba8a84239aee8f27aebb91975cee191.zip
dev-ruby/shotgun: add 0.9.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/shotgun/shotgun-0.9.2.ebuild')
-rw-r--r--dev-ruby/shotgun/shotgun-0.9.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/shotgun/shotgun-0.9.2.ebuild b/dev-ruby/shotgun/shotgun-0.9.2.ebuild
new file mode 100644
index 000000000000..e9c39b357f46
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="https://github.com/rtomayko/shotgun"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend 'dev-ruby/rack:*'
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_shotgun_static.rb || die
+ ${RUBY} -Ilib test/test_shotgun_loader.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/shotgun.1
+}