summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-12-04 08:30:32 +0100
committerHans de Graaff <graaff@gentoo.org>2024-12-04 12:25:18 +0100
commit867b0a5306f38f66d6b0d185f96b29f5b67f9a25 (patch)
treecdb4e653eb5451429944835791df6365de91ced9 /dev-ruby
parentdev-ruby/minitest: add 5.25.4 (diff)
downloadgentoo-867b0a5306f38f66d6b0d185f96b29f5b67f9a25.tar.gz
gentoo-867b0a5306f38f66d6b0d185f96b29f5b67f9a25.tar.bz2
gentoo-867b0a5306f38f66d6b0d185f96b29f5b67f9a25.zip
dev-ruby/securerandom: add 0.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/securerandom/Manifest1
-rw-r--r--dev-ruby/securerandom/securerandom-0.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/securerandom/Manifest b/dev-ruby/securerandom/Manifest
index c78a82b6f8cc..f60584bcc0b0 100644
--- a/dev-ruby/securerandom/Manifest
+++ b/dev-ruby/securerandom/Manifest
@@ -1,2 +1,3 @@
DIST securerandom-0.3.1.tar.gz 10593 BLAKE2B bfa122d91f356c3164924ba0409e74da10822ee2298293adeb3c066c5f1d89e4b84755c4b46e970eec3fbce29cef41c698c69eb55bec200acb36446a04635c00 SHA512 1d312c66d6e66afce3d8e812a5fd9baa1a763d022b184227d758aed26d97d12ab69ed16c62163a76d6bc0eac4d4219f0f63bdd846a0078bb0c6a19b67e27cca3
DIST securerandom-0.3.2.tar.gz 12145 BLAKE2B 023623d6ede0ec01a777e36ed15c37fdff0dbe73bb9892f3b179c0e736f86aaa234d36a88b278fc8a75b9212b021744cdd5081ab9769a6e5d073005ec0275d8d SHA512 9acdc671d2cdddb8e4ecaa5641fe403be47660c7441c94d07339f5888d1f574c7a001b329f9f98ff0ecdb9bebac77f843ed8f4761367d6dd29666a1e6c334e19
+DIST securerandom-0.4.0.tar.gz 7016 BLAKE2B be20ba9405d99cb820c3aafaf5cf5d88c422e5ec696c6fe8d9c1c9f1ae5dbde34c1010b3080a20c5b7f105db49c3d448fa6fc4f90189c864582be6de6d7b4f59 SHA512 b60dd366de6bb8680129d71d2c9d1dbbe6b79101d1a5be2bfabc43980ff34eb730faab20532075b504e702b9952f6e42a3e8246bff7ec00e7c9c4bc685586607
diff --git a/dev-ruby/securerandom/securerandom-0.4.0.ebuild b/dev-ruby/securerandom/securerandom-0.4.0.ebuild
new file mode 100644
index 000000000000..18c7777cc88c
--- /dev/null
+++ b/dev-ruby/securerandom/securerandom-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="securerandom.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Interface for secure random number generator"
+HOMEPAGE="https://github.com/ruby/securerandom"
+SRC_URI="https://github.com/ruby/securerandom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}