summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bless/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bless/files')
-rw-r--r--dev-util/bless/files/bless-0.5.2-mono-2.patch118
-rw-r--r--dev-util/bless/files/bless-0.6.0-docpath.patch71
-rw-r--r--dev-util/bless/files/bless-0.6.0-pixmap.patch20
3 files changed, 209 insertions, 0 deletions
diff --git a/dev-util/bless/files/bless-0.5.2-mono-2.patch b/dev-util/bless/files/bless-0.5.2-mono-2.patch
new file mode 100644
index 000000000000..4271046c56d4
--- /dev/null
+++ b/dev-util/bless/files/bless-0.5.2-mono-2.patch
@@ -0,0 +1,118 @@
+diff -Naur blessbroken/src/gui/plugins/BitwiseOperationsPlugin.cs bless-0.5.2/src/gui/plugins/BitwiseOperationsPlugin.cs
+--- blessbroken/src/gui/plugins/BitwiseOperationsPlugin.cs 2007-08-25 09:54:21.000000000 +0200
++++ bless-0.5.2/src/gui/plugins/BitwiseOperationsPlugin.cs 2008-07-08 01:33:38.352260344 +0200
+@@ -102,7 +102,7 @@
+ uim.InsertActionGroup(group, 0);
+ uim.AddUiFromString(uiXml);
+
+- performAction = (Action)uim.GetAction("/DefaultAreaPopup/ExtraAreaPopupItems/PerformBitwiseOperation");
++ performAction = (Gtk.Action)uim.GetAction("/DefaultAreaPopup/ExtraAreaPopupItems/PerformBitwiseOperation");
+
+ uim.EnsureUpdate();
+
+diff -Naur blessbroken/src/gui/plugins/EditOperationsPlugin.cs bless-0.5.2/src/gui/plugins/EditOperationsPlugin.cs
+--- blessbroken/src/gui/plugins/EditOperationsPlugin.cs 2007-08-25 09:54:21.000000000 +0200
++++ bless-0.5.2/src/gui/plugins/EditOperationsPlugin.cs 2008-07-08 01:35:00.027629029 +0200
+@@ -151,12 +151,12 @@
+ void ConnectEditAccelerators(bool v)
+ {
+ if (editAccelCount == 0 && v == true) {
+- foreach(Action a in editActionGroup.ListActions())
++ foreach(Gtk.Action a in editActionGroup.ListActions())
+ a.ConnectAccelerator();
+ editAccelCount = 1;
+ }
+ else if (editAccelCount == 1 && v == false) {
+- foreach(Action a in editActionGroup.ListActions())
++ foreach(Gtk.Action a in editActionGroup.ListActions())
+ a.DisconnectAccelerator();
+ editAccelCount = 0;
+ }
+@@ -207,15 +207,15 @@
+ uim.InsertActionGroup(miscActionGroup, 0);
+
+ uim.AddUiFromString(uiXml);
+- UndoAction = (Action)uim.GetAction("/menubar/Edit/Undo");
+- RedoAction = (Action)uim.GetAction("/menubar/Edit/Redo");
+- CutAction = (Action)uim.GetAction("/menubar/Edit/Cut");
+- CopyAction = (Action)uim.GetAction("/menubar/Edit/Copy");
+- PasteAction = (Action)uim.GetAction("/menubar/Edit/Paste");
+- DeleteAction = (Action)uim.GetAction("/menubar/Edit/Delete");
++ UndoAction = (Gtk.Action)uim.GetAction("/menubar/Edit/Undo");
++ RedoAction = (Gtk.Action)uim.GetAction("/menubar/Edit/Redo");
++ CutAction = (Gtk.Action)uim.GetAction("/menubar/Edit/Cut");
++ CopyAction = (Gtk.Action)uim.GetAction("/menubar/Edit/Copy");
++ PasteAction = (Gtk.Action)uim.GetAction("/menubar/Edit/Paste");
++ DeleteAction = (Gtk.Action)uim.GetAction("/menubar/Edit/Delete");
+
+
+- foreach (Action a in editActionGroup.ListActions()) {
++ foreach (Gtk.Action a in editActionGroup.ListActions()) {
+ // for some reason the accelerators are connected twice
+ // ... so disconnect them twice
+ for (int i = 0; i < 2; i++)
+diff -Naur blessbroken/src/gui/plugins/FileOperationsPlugin.cs bless-0.5.2/src/gui/plugins/FileOperationsPlugin.cs
+--- blessbroken/src/gui/plugins/FileOperationsPlugin.cs 2007-08-25 09:54:21.000000000 +0200
++++ bless-0.5.2/src/gui/plugins/FileOperationsPlugin.cs 2008-07-08 01:35:48.083280812 +0200
+@@ -159,11 +159,11 @@
+
+ uim.InsertActionGroup(group, 0);
+ uim.AddUiFromString(uiXml);
+- SaveAction = (Action)uim.GetAction("/menubar/File/Save");
+- SaveAsAction = (Action)uim.GetAction("/menubar/File/SaveAs");
+- CloseAction = (Action)uim.GetAction("/menubar/File/Close");
+- QuitAction = (Action)uim.GetAction("/menubar/File/Quit");
+- RevertAction = (Action)uim.GetAction("/menubar/File/Revert");
++ SaveAction = (Gtk.Action)uim.GetAction("/menubar/File/Save");
++ SaveAsAction = (Gtk.Action)uim.GetAction("/menubar/File/SaveAs");
++ CloseAction = (Gtk.Action)uim.GetAction("/menubar/File/Close");
++ QuitAction = (Gtk.Action)uim.GetAction("/menubar/File/Quit");
++ RevertAction = (Gtk.Action)uim.GetAction("/menubar/File/Revert");
+
+ uim.EnsureUpdate();
+
+diff -Naur blessbroken/src/gui/plugins/FindReplacePlugin.cs bless-0.5.2/src/gui/plugins/FindReplacePlugin.cs
+--- blessbroken/src/gui/plugins/FindReplacePlugin.cs 2007-08-25 09:54:21.000000000 +0200
++++ bless-0.5.2/src/gui/plugins/FindReplacePlugin.cs 2008-07-08 01:36:15.427064932 +0200
+@@ -38,10 +38,10 @@
+ DataBook dataBook;
+ FindReplaceWidget widget;
+
+- Action FindAction;
+- Action FindNextAction;
+- Action FindPreviousAction;
+- Action ReplaceAction;
++ Gtk.Action FindAction;
++ Gtk.Action FindNextAction;
++ Gtk.Action FindPreviousAction;
++ Gtk.Action ReplaceAction;
+
+ IFinder finder;
+ Window mainWindow;
+@@ -162,10 +162,10 @@
+ uim.InsertActionGroup(group, 0);
+ uim.AddUiFromString(uiXml);
+
+- FindAction = (Action)uim.GetAction("/menubar/Search/Find");
+- FindNextAction = (Action)uim.GetAction("/menubar/Search/FindNext");
+- FindPreviousAction = (Action)uim.GetAction("/menubar/Search/FindPrevious");
+- ReplaceAction = (Action)uim.GetAction("/menubar/Search/Replace");
++ FindAction = (Gtk.Action)uim.GetAction("/menubar/Search/Find");
++ FindNextAction = (Gtk.Action)uim.GetAction("/menubar/Search/FindNext");
++ FindPreviousAction = (Gtk.Action)uim.GetAction("/menubar/Search/FindPrevious");
++ ReplaceAction = (Gtk.Action)uim.GetAction("/menubar/Search/Replace");
+
+ uim.EnsureUpdate();
+
+diff -Naur blessbroken/src/gui/plugins/HistoryPlugin.cs bless-0.5.2/src/gui/plugins/HistoryPlugin.cs
+--- blessbroken/src/gui/plugins/HistoryPlugin.cs 2007-08-25 09:54:21.000000000 +0200
++++ bless-0.5.2/src/gui/plugins/HistoryPlugin.cs 2008-07-08 01:36:49.074794118 +0200
+@@ -61,7 +61,7 @@
+ // clear previous list
+ uiManager.RemoveUi(mergeId);
+ uiManager.RemoveActionGroup(historyActionGroup);
+- foreach(Action action in historyActionGroup.ListActions()) {
++ foreach(Gtk.Action action in historyActionGroup.ListActions()) {
+ historyActionGroup.Remove(action);
+ }
+
diff --git a/dev-util/bless/files/bless-0.6.0-docpath.patch b/dev-util/bless/files/bless-0.6.0-docpath.patch
new file mode 100644
index 000000000000..b1121424d88b
--- /dev/null
+++ b/dev-util/bless/files/bless-0.6.0-docpath.patch
@@ -0,0 +1,71 @@
+diff --git a/Makefile.am b/Makefile.am
+index 33f265b..346326d 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,9 @@
+ EXTRA_DIST = AUTHORS COPYING NEWS README README.packaging \
+ bless.mdp bless.mds bless.spec autogen.sh bless.mi
+
++doc_DATA = AUTHORS COPYING INSTALL ChangeLog NEWS \
++ README README.packaging bless.spec
++
+ SUBDIRS = po builder src bin data doc . tests
+
+ DIST_SUBDIRS= po builder src bin doc data tests
+@@ -34,11 +37,5 @@ bless-builder:
+ dist-hook:
+ bzr log > $(distdir)/ChangeLog
+
+-install-data-local:
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)
+- $(INSTALL_DATA) AUTHORS COPYING INSTALL ChangeLog NEWS \
+- README README.packaging bless.spec \
+- $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)
+-
+ uninstall-local:
+ rm -rf $(DESTDIR)$(libdir)/$(PACKAGE_NAME)
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index b18e94a..d7eecc6 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,4 +1 @@
+ SUBDIRS= developer user
+-
+-uninstall-local:
+- rm -rf $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)
+diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
+index 729b295..58a1358 100644
+--- a/doc/user/Makefile.am
++++ b/doc/user/Makefile.am
+@@ -7,6 +7,11 @@ CLEANFILES=$(OMF)
+
+ noinst_SCRIPTS=$(OMF)
+
++docmandir=$(docdir)/user
++docfigsdir=$(docmandir)/figures
++
++docfigs_DATA=$(FIGURES)
++docman_DATA=$(DOCS) $(wildcard *.html)
+
+ $(OMF): $(OMF).in
+ if [ -x `which scrollkeeper-preinstall` ]; then \
+@@ -27,11 +32,6 @@ dist-hook: doc
+ rm html_file_list
+
+ install-data-local:
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user/figures
+- $(INSTALL_DATA) $(DOCS) $(wildcard *.html) \
+- $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user
+- $(INSTALL_DATA) $(FIGURES) $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user/figures
+ $(INSTALL) -d $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)
+ $(INSTALL_DATA) $(OMF) $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)
+ if WITH_SCROLLKEEPER
+@@ -39,7 +39,6 @@ if WITH_SCROLLKEEPER
+ endif
+
+ uninstall-local:
+- rm -rf $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user
+ rm $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)/$(OMF)
+ if WITH_SCROLLKEEPER
+ scrollkeeper-update -o $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)
diff --git a/dev-util/bless/files/bless-0.6.0-pixmap.patch b/dev-util/bless/files/bless-0.6.0-pixmap.patch
new file mode 100644
index 000000000000..441a9e2bfb79
--- /dev/null
+++ b/dev-util/bless/files/bless-0.6.0-pixmap.patch
@@ -0,0 +1,20 @@
+=== modified file 'src/gui/drawers/HexDrawer.cs'
+--- src/gui/drawers/HexDrawer.cs 2007-06-13 12:20:53 +0000
++++ src/gui/drawers/HexDrawer.cs 2009-04-10 23:21:41 +0000
+@@ -57,11 +57,14 @@
+
+ //System.Console.WriteLine(s);
+
+- pangoLayout.SetText(s);
++ pangoLayout.SetText(s.Substring(0,256));
+
+
+ gc.RgbFgColor = fg;
+ pix.DrawLayout(gc, 0, 0, pangoLayout);
++
++ pangoLayout.SetText(s.Substring(256,256));
++ pix.DrawLayout(gc, 128*2*width, 0, pangoLayout);
+
+ return pix;
+ }
+