summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2023-08-27 12:15:14 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-08-27 12:38:57 +0200
commit986ebe61212430cf58c9d36dd23046ce160ae091 (patch)
treec45e09e778b41eb1e459779683b22448f1e41c20 /dev-util/clippy
parentdev-libs/json-c: update 9999 (diff)
downloadgentoo-986ebe61212430cf58c9d36dd23046ce160ae091.tar.gz
gentoo-986ebe61212430cf58c9d36dd23046ce160ae091.tar.bz2
gentoo-986ebe61212430cf58c9d36dd23046ce160ae091.zip
dev-util/clippy: add 9.0
Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-util/clippy')
-rw-r--r--dev-util/clippy/Manifest1
-rw-r--r--dev-util/clippy/clippy-9.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/clippy/Manifest b/dev-util/clippy/Manifest
index 36af5124eb28..bf8e1272756c 100644
--- a/dev-util/clippy/Manifest
+++ b/dev-util/clippy/Manifest
@@ -1,3 +1,4 @@
DIST clippy-8.4.2.tar.gz 9893223 BLAKE2B 670fb131c2959b0ce4f3133ef38caeb7832275844b16f8582a693033f5466ad0eb98ab45ed9615e0a121ab80bf034edafe7ee816c47d767bd8a13b52f3138eac SHA512 1ee9d17ef3b85c5c10df624a6560bcacb2b5daa3d6231e457f06d9eb6e5ccf375064a46e809d851c23cb6daf7a4299d1f25be589992ef729e80f9bad41a8d7f7
DIST clippy-8.5.2.tar.gz 10076639 BLAKE2B 2e2aca4e42757f66c9ca4725826c6cc1d611930490eed2a175ca5b56910f2c09a9d842b2a9370a64a9fdac6a6314bd4573be609d14dbf956049d9fbf49310404 SHA512 1afa6ca1a41096aa47dc2fc39ab87290b3cbf634a1632e7910a5b69d2816998fbccbca616f261a410aa146a21dd26d12b7e6812da4ec08545b1500f8b546b972
DIST clippy-8.5.tar.gz 10068379 BLAKE2B ed7aa538997bdbfde0370f36a8980ad3ae882a2325cdc7c3b2bdba9d6a43cd9ca04ff96b94b7827e06593a15c104cdadbd2632e136eb2d68e7ed87095a9294a4 SHA512 13e2ea8642fc00b565e9a36d2d59abe5d0e11caf646199cd928184fda2de004bda9892ae8a2f91870d5ac218bb127725663b693e4d764e5b21c942bb20b8d66f
+DIST frr-9.0.tar.gz 10332694 BLAKE2B 82221df6da189d5e687af4618af71933eb512413126dfb312bfcc663e5fc6f85e29c33da84117f40598452e6033cb24e9cba8d28f00d63fee2bf45a43babef17 SHA512 d3af6c24abbc8745f9646a22c023bd1d0e155776ffd09c9dd0b81b93c383723c9e7dd987319551db85dab5fd45d47cbcbf47a1ae1b6861cd7930bc27f18d2e25
diff --git a/dev-util/clippy/clippy-9.0.ebuild b/dev-util/clippy/clippy-9.0.ebuild
new file mode 100644
index 000000000000..5c3fda52b99a
--- /dev/null
+++ b/dev-util/clippy/clippy-9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="frr-${PV}"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone clippy tool built from FRR sources"
+HOMEPAGE="https://frrouting.org/"
+SRC_URI="https://github.com/FRRouting/frr/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/frr-${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# standalone clippy does not have any tests
+# restrict to prevent bug 811753
+RESTRICT="test"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ mallinfo # check in configure is fallback is needed
+ mallinfo2 # check in configure is fallback is needed
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #884291
+ unset YACC
+ export LEX=flex
+
+ econf --enable-clippy-only
+}
+
+src_install() {
+ # 830087
+ find "lib" -type f -name "clippy" -print0 |
+ xargs -0 file | grep executable | grep ELF | cut -f 1 -d : |
+ xargs -I '{}' dobin '{}' ||
+ die "Failed to install 'lib/clippy'"
+}