summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cmdtest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cmdtest')
-rw-r--r--dev-util/cmdtest/Manifest2
-rw-r--r--dev-util/cmdtest/cmdtest-0.10.ebuild28
-rw-r--r--dev-util/cmdtest/cmdtest-0.6.ebuild28
-rw-r--r--dev-util/cmdtest/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/cmdtest/Manifest b/dev-util/cmdtest/Manifest
new file mode 100644
index 000000000000..d0966276b4c0
--- /dev/null
+++ b/dev-util/cmdtest/Manifest
@@ -0,0 +1,2 @@
+DIST cmdtest_0.10.orig.tar.gz 34152 SHA256 d9a421ed916213c5c6660a1057a560afff6e5c7606fe0e1cba3a359f66f23068 SHA512 da3e042c1c7d4379316fb6e3bc642a2e57fa12004434296c30f77debc7662bed49726057eb280461d18308739e86082fd96efe1642d1c531321b1c10f06d3595 WHIRLPOOL eadb47185a977d74ff046654b9845be9e49b859a88d10001f6eb809b1de8cb7697f840942dca100007ef00c98faafc9d7f127c9359108148372fd7175b88c509
+DIST cmdtest_0.6.orig.tar.gz 18603 SHA256 7367d4c6db3b84f6c74209fed179749434ac84dfe6e039fc1a58dd99a5048802 SHA512 67ef446034890bd93e66b8577a5d1f70e490550e9e72204225eff0d91f15c8610c4d7b7167461c08b070ed108d8326e3c9ef87cfc339fbe320c17c2be87ed429 WHIRLPOOL ac57c94497b6da5740435f513112574bc41e152605ecce89e9cd5a788f656c49ec8a5a318eef536754bdd8ec5a9bc204032ed1b4ffb847462ffe52eeb1dca5a9
diff --git a/dev-util/cmdtest/cmdtest-0.10.ebuild b/dev-util/cmdtest/cmdtest-0.10.ebuild
new file mode 100644
index 000000000000..c90222e27e0a
--- /dev/null
+++ b/dev-util/cmdtest/cmdtest-0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="black box tests Unix command line tools"
+HOMEPAGE="http://liw.fi/cmdtest/"
+SRC_URI="http://code.liw.fi/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/ttystatus
+"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}
diff --git a/dev-util/cmdtest/cmdtest-0.6.ebuild b/dev-util/cmdtest/cmdtest-0.6.ebuild
new file mode 100644
index 000000000000..deceb8ea4fa8
--- /dev/null
+++ b/dev-util/cmdtest/cmdtest-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="black box tests Unix command line tools"
+HOMEPAGE="http://liw.fi/cmdtest/"
+SRC_URI="http://code.liw.fi/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/ttystatus
+"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}
diff --git a/dev-util/cmdtest/metadata.xml b/dev-util/cmdtest/metadata.xml
new file mode 100644
index 000000000000..ea7bd021a21e
--- /dev/null
+++ b/dev-util/cmdtest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>