summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-19 16:34:03 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-19 20:22:28 +0200
commit6c0b3b0a9d6f133dbe3ca0051cd66fbee91cc126 (patch)
tree2838679da1eeaf26bc2a44e65e525b62b49dfc33 /dev-util/debootstrap/debootstrap-1.0.102.ebuild
parentapp-benchmarks/i7z: Fix CPU detection (patch from Debian) (diff)
downloadgentoo-6c0b3b0a9d6f133dbe3ca0051cd66fbee91cc126.tar.gz
gentoo-6c0b3b0a9d6f133dbe3ca0051cd66fbee91cc126.tar.bz2
gentoo-6c0b3b0a9d6f133dbe3ca0051cd66fbee91cc126.zip
dev-util/debootstrap: Version 1.0.102.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/debootstrap/debootstrap-1.0.102.ebuild')
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.102.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/debootstrap/debootstrap-1.0.102.ebuild b/dev-util/debootstrap/debootstrap-1.0.102.ebuild
new file mode 100644
index 000000000000..93ffd5d2d1aa
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.102.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}