summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dogtail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dogtail')
-rw-r--r--dev-util/dogtail/Manifest1
-rw-r--r--dev-util/dogtail/dogtail-0.9.0-r2.ebuild62
-rw-r--r--dev-util/dogtail/files/dogtail-0.9.0-gentoo-paths.patch43
-rw-r--r--dev-util/dogtail/files/dogtail-0.9.0-get-user.patch28
-rw-r--r--dev-util/dogtail/metadata.xml5
5 files changed, 139 insertions, 0 deletions
diff --git a/dev-util/dogtail/Manifest b/dev-util/dogtail/Manifest
new file mode 100644
index 000000000000..ca8fee9b8993
--- /dev/null
+++ b/dev-util/dogtail/Manifest
@@ -0,0 +1 @@
+DIST dogtail-0.9.0.tar.gz 119882 SHA256 564dae5fba4fa3a7f6d53503e0877dad56ae8bce10e181d3d2c0bdbf063f4e36 SHA512 cf2956fad923f0f325f5dc3cd8f5a575491f6c455e2fa597b034b09e1579054b84b6ae80b67cbbe161c012c0de48457f872cfe27a5e0274447d32e21e4a8360d WHIRLPOOL 771606a4bc3d59bd75df85ab9ef3dd8bd4e28161e13fc792bb4108f7b058db18f42c1174499b90d3c307c3302e254278aecf94e03ff894222bc7f12021611c1f
diff --git a/dev-util/dogtail/dogtail-0.9.0-r2.ebuild b/dev-util/dogtail/dogtail-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..9eaf0b20d149
--- /dev/null
+++ b/dev-util/dogtail/dogtail-0.9.0-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1 gnome2-utils fdo-mime
+
+DESCRIPTION="GUI test tool and automation framework using accessibility framework"
+HOMEPAGE="https://fedorahosted.org/dogtail/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-base/xorg-server[xvfb]
+ x11-apps/xinit
+"
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ # Install docs in one place
+ sed "s:doc/${PN}:doc/${PF}:" -i setup.py || die
+
+ # Fix current user detection, upstream bug #46
+ # Also, respect TMPDIR
+ epatch "${FILESDIR}"/${PN}-0.9.0-get-user.patch
+
+ # Upstream loads resources relative to __file__, which doesn't work with
+ # gentoo's dev-lang/python-exec. So we need to add hard-coded paths.
+ epatch "${FILESDIR}"/${PN}-0.9.0-gentoo-paths.patch
+ sed -e "s:@EPREFIX_USR@:'${EPREFIX}/usr':" -i sniff/sniff || die "sed failed"
+
+ distutils-r1_src_prepare
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/dogtail/files/dogtail-0.9.0-gentoo-paths.patch b/dev-util/dogtail/files/dogtail-0.9.0-gentoo-paths.patch
new file mode 100644
index 000000000000..7c4acfb62884
--- /dev/null
+++ b/dev-util/dogtail/files/dogtail-0.9.0-gentoo-paths.patch
@@ -0,0 +1,43 @@
+diff --git a/sniff/sniff b/sniff/sniff
+index 86771f9..05f4c6a 100755
+--- a/sniff/sniff
++++ b/sniff/sniff
+@@ -45,23 +45,14 @@ class SniffApp(object):
+ if os.path.exists('sniff.ui'):
+ self.builder.add_from_file('sniff.ui')
+ else:
+- import os
+- path = os.path.abspath(
+- os.path.join(__file__, os.path.pardir, os.path.pardir))
+- if path is '/': # in case the path is /bin/sniff
+- path = '/usr'
+- self.builder.add_from_file(path +
++ self.builder.add_from_file(@EPREFIX_USR@ +
+ '/share/dogtail/glade/sniff.ui')
+ self.app = self.builder.get_object(self.appName)
+ try:
+ self.app.set_icon_from_file('../icons/dogtail-head.svg')
+ except Exception:
+ import os
+- path = os.path.abspath(
+- os.path.join(__file__, os.path.pardir, os.path.pardir))
+- if path is '/':
+- path = '/usr'
+- self.app.set_icon_from_file(os.path.join(path,
++ self.app.set_icon_from_file(os.path.join(@EPREFIX_USR@,
+ 'share/icons/hicolor/scalable/apps/dogtail-head.svg'))
+ self.setUpWidgets()
+ self.connectSignals()
+@@ -666,11 +657,7 @@ def loadIcon(iconName):
+ pixbuf = GdkPixbuf.Pixbuf.new_from_file('icons/' + iconName)
+ except GObject.GError:
+ import os
+- path = os.path.abspath(
+- os.path.join(__file__, os.path.pardir, os.path.pardir))
+- if path is '/':
+- path = '/usr'
+- iconName = os.path.join(path, 'share/dogtail/icons/', iconName)
++ iconName = os.path.join(@EPREFIX_USR@, 'share/dogtail/icons/', iconName)
+ pixbuf = GdkPixbuf.Pixbuf.new_from_file(iconName)
+ return pixbuf
+
diff --git a/dev-util/dogtail/files/dogtail-0.9.0-get-user.patch b/dev-util/dogtail/files/dogtail-0.9.0-get-user.patch
new file mode 100644
index 000000000000..07a6ad807467
--- /dev/null
+++ b/dev-util/dogtail/files/dogtail-0.9.0-get-user.patch
@@ -0,0 +1,28 @@
+Do not use USER as it can be unset.
+
+Use LOGNAME first as recommended by python documentation, then try alternatives.
+
+Also, use tempfile to respect environment variables changing tmpdir.
+
+Upstream: https://fedorahosted.org/dogtail/ticket/46
+Debian: http://bugs.debian.org/743500
+
+--- a/dogtail/config.py 2015-06-08 22:59:08.664107350 +0200
++++ b/dogtail/config.py 2015-06-08 22:57:54.433669729 +0200
+@@ -6,11 +6,15 @@ __author__ = "Zack Cerza <zcerza@redhat.com>, David Malcolm <dmalcolm@redhat.com
+ import os
+ import sys
+ import locale
++import tempfile
+
+
+ def _userTmpDir(baseName):
+ # i.e. /tmp/dogtail-foo
+- return '-'.join(('/'.join(('/tmp', baseName)), os.environ['USER']))
++ return '-'.join((
++ '/'.join((tempfile.gettempdir(), baseName)),
++ os.getenv('LOGNAME', os.getenv('USER', os.getlogin()))
++ ))
+
+
+ class _Config(object):
diff --git a/dev-util/dogtail/metadata.xml b/dev-util/dogtail/metadata.xml
new file mode 100644
index 000000000000..dad9001338dc
--- /dev/null
+++ b/dev-util/dogtail/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>