summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-06-21 12:23:55 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-06-21 12:24:18 -0500
commit0bae38cb37347bf2a69aa82a444e001de9f53016 (patch)
tree70f6a6c33c20182332799411792cb2607e8391b2 /dev-util/gitlab-runner
parentdev-python/kiwisolver: Remove old (diff)
downloadgentoo-0bae38cb37347bf2a69aa82a444e001de9f53016.tar.gz
gentoo-0bae38cb37347bf2a69aa82a444e001de9f53016.tar.bz2
gentoo-0bae38cb37347bf2a69aa82a444e001de9f53016.zip
dev-util/gitlab-runner: add 15.1.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.1.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index d32cd47ddcf4..8817c2392c12 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-14.9.2-deps.tar.xz 142907928 BLAKE2B fb61c7b03d3dd63196bb4de0
DIST gitlab-runner-14.9.2.tar.gz 1260233 BLAKE2B 9632c01ce05375ccec038392c978eedb66287e48263347b73194d4cadab122822bdf6c1b5cdec324501c636e4fe68e65623aeae42b1d8bb34f38281142367da1 SHA512 2f3e5c729bd443fd4943c6521762155fd7b7848d3a64634947be5e8b8e31dd19765502d5abb604b872e1e1fc1fa35e05d49075122f7edeed82760ae53970de32
DIST gitlab-runner-15.0.0-deps.tar.xz 142912160 BLAKE2B e38db204edb80c76524f58aa125bbd17523e239e30533f93e009b73d8cf571f071967dc50c12ba8622b7f03b0ac0565bb5702ccc33c495501321a73cede009e1 SHA512 f8870cd3a33ff778f5fe99b12fff2944d457006fd1c59d5a289650606d5b69fb56f50b0b88725eb5a1e4d30ed52db5c136475f03e0c0597a6544ee86f0c27fdd
DIST gitlab-runner-15.0.0.tar.gz 1273838 BLAKE2B ac80f8bdd4a750f86d34e98cefad9d3c4e345d9607669c1205e5fbba28f25a83be27c43850383fd81e8222426ed31c2738a59c22cd5b6b6e60765295e7437f17 SHA512 8ba54e690fc45c1e22d174b649fbe3cf78707fd5a146c738c73cba045e6ac00499ddedd7a5f905c0c7e4e804a533d3fc718f8f7ac3c9ec5581de4dd9b3599c80
+DIST gitlab-runner-15.1.0-deps.tar.xz 140961872 BLAKE2B 711d2d7b75ab287216963a3871bfcd755d4b5478a37bffcbc64dbe32b93b2c08ca94b0048847697ed83031fc160d9e36589734ccda36526e67d5b4ae621a644b SHA512 58d23e8d25a8c033b517c8f21e6a24c3c449eb7365ae074c18bbda6d2030cc053371da8d5899319a767c922c5923a9042629fe191ba714c3553eadaeb2756a2d
+DIST gitlab-runner-15.1.0.tar.gz 1287049 BLAKE2B 76b1c5b535e328941741e55e460de158bcf54d8fa76bc70eba1eed63e7e892f126cdec992cf34ad4c0227f0ee5ba33ec06cea8ba4efd47bf36a540869f71b706 SHA512 7892b4ccfa5973f20deda365e337b8f70e159a9387b6823eada4b39a0cabcd078af08c9bc45e629aa432f49c72f71df6b04fc1cecb72bc2e9c9cd018fc04299b
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.1.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.1.0.ebuild
new file mode 100644
index 000000000000..df4a8331c7a6
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.1.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=76984217
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}