summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-05-24 15:10:37 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-05-24 15:10:58 -0500
commitb58d6046e55d86d1e7cdecbc73b34c2cd3d140cb (patch)
treee911ebead92ad1c5e1522fb4d5580097b5f1880a /dev-util/gitlab-runner
parentapp-misc/tmuxp: fix deps to unbreak CI (diff)
downloadgentoo-b58d6046e55d86d1e7cdecbc73b34c2cd3d140cb.tar.gz
gentoo-b58d6046e55d86d1e7cdecbc73b34c2cd3d140cb.tar.bz2
gentoo-b58d6046e55d86d1e7cdecbc73b34c2cd3d140cb.zip
dev-util/gitlab-runner: add 15.0.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.0.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 80333e7f8a38..d32cd47ddcf4 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -2,3 +2,5 @@ DIST gitlab-runner-14.10.1-deps.tar.xz 142897024 BLAKE2B 353b209e62b87edd7f684c2
DIST gitlab-runner-14.10.1.tar.gz 1265690 BLAKE2B c455c08f1530b4fa6d63d74736adeb7cfb76c5f4f56577e2c22ba64630c88a3b0933fd0e3fbcf173d7263f6150bd77491fa091c5c8a4821dabf4bfee24928a52 SHA512 5b3a6b1b13569a9f24206f078bd864689fc6cf9c7f249b3fc5adb36e9c59bc6b53f218a7e31aab8537f188500f072a8e73ad9422e03e2eb44c21521c903044a1
DIST gitlab-runner-14.9.2-deps.tar.xz 142907928 BLAKE2B fb61c7b03d3dd63196bb4de0042a3c65035a3fc132435d7844635bb968a6bfe43e05fca053bfa96ba22cc9fd601d533857bffdf8bd734e90e86fefce8091da34 SHA512 d077cc1220ad33196655e578937c910c7b368eef57bb96d385eac0957e5f8902bb3720b1614f3179753929f25589a8d1d543bcb61d4cf5972bf4ada96a4056d8
DIST gitlab-runner-14.9.2.tar.gz 1260233 BLAKE2B 9632c01ce05375ccec038392c978eedb66287e48263347b73194d4cadab122822bdf6c1b5cdec324501c636e4fe68e65623aeae42b1d8bb34f38281142367da1 SHA512 2f3e5c729bd443fd4943c6521762155fd7b7848d3a64634947be5e8b8e31dd19765502d5abb604b872e1e1fc1fa35e05d49075122f7edeed82760ae53970de32
+DIST gitlab-runner-15.0.0-deps.tar.xz 142912160 BLAKE2B e38db204edb80c76524f58aa125bbd17523e239e30533f93e009b73d8cf571f071967dc50c12ba8622b7f03b0ac0565bb5702ccc33c495501321a73cede009e1 SHA512 f8870cd3a33ff778f5fe99b12fff2944d457006fd1c59d5a289650606d5b69fb56f50b0b88725eb5a1e4d30ed52db5c136475f03e0c0597a6544ee86f0c27fdd
+DIST gitlab-runner-15.0.0.tar.gz 1273838 BLAKE2B ac80f8bdd4a750f86d34e98cefad9d3c4e345d9607669c1205e5fbba28f25a83be27c43850383fd81e8222426ed31c2738a59c22cd5b6b6e60765295e7437f17 SHA512 8ba54e690fc45c1e22d174b649fbe3cf78707fd5a146c738c73cba045e6ac00499ddedd7a5f905c0c7e4e804a533d3fc718f8f7ac3c9ec5581de4dd9b3599c80
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.0.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.0.0.ebuild
new file mode 100644
index 000000000000..d91c8bf83913
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+GIT_COMMIT=c6bb62f6a
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}